3
$\begingroup$

I created a scene using HDRI in which an airdrop is there on ground but airdrop shadow is not visible which makes it looks unreal. I've used a shadow catcher and it is even having particle system to imitate grass like structure but shadow is not visible. What should I do? P.S. Model requires some work.

Here's render preview: enter image description here

Blender File: https://drive.google.com/file/d/1WpLjv3KZj5n3izid2DTM14uaYUzKG8bO/view?usp=sharing

$\endgroup$
3
  • 1
    $\begingroup$ Most of all I would say that your object seems too dark and saturated compared to your scene, maybe you should decrease these values, either in the Compositor or directly playing with the material? $\endgroup$
    – moonboots
    Jun 20 at 7:55
  • 1
    $\begingroup$ please provide your blend file. Are you using cycles? "normally" if you have cycles and you add a plane under your object (big enough) and check the "shadow" catcher checkbox it just "works" with HDRI. [1]: i.stack.imgur.com/FDyzV.jpg $\endgroup$
    – Chris
    Jun 20 at 8:02
  • $\begingroup$ Possibly related: Eevee get darker shadows $\endgroup$ Jun 20 at 11:17
4
$\begingroup$

You are not using HDRi (.hdr type of file) to light your scene. Your Environment texture is JPEG file that will never light your scene properly (since it is only 8-bit, you need .hdr or .exr files that can be 32-bit color depth).

enter image description here Color Management > Filmic > High Contrast


Tips:

  • Your grass is pointing only upward, that doesn't look natural, Go to Particle Properties > Velocity > Randomize set to 0.08
  • If you need to catch just the box shadow you don't need such a big grass area. You can scale it down to speed up your render.
  • What I like to do instead of Shadow Catcher feature is to use shader to catch shadow and indirect light, emissive light ... It is also great as feedback if environment texture lights properly. But it failed with grass particle system here.
  • Anyway ... you have to set some material otherwise none material means default white material for shadow catcher object ...

enter image description here

... that is still participating in render with Indirect lights.

enter image description here

Make it more integrated you would have to add some material ... like with a single color picked from ground ... or material in the link above ...

enter image description here

$\endgroup$
4
$\begingroup$

CYCLES

How does shadow catcher work?

  1. Add an object (cube)

  2. Add a plane (big enough) under the cube

  3. check the checkbox "shadow catcher" for the plane

enter image description here

  1. add an HDRI

  2. result:

enter image description here

UPDATE

Unfortunately you did not File->External data-> Pack Resources so all i saw was pink :(

But...i inserted my own HDRI, deleted your two materials you gave the shadow catcher (just delete all and add the default one) and then i got:

enter image description here

$\endgroup$
5
  • $\begingroup$ Did the same but added a particle system to it so that it imitates grass, is that wrong? & added the link to .blend file. $\endgroup$
    – Aman Kumar
    Jun 20 at 8:11
  • $\begingroup$ i don't think this is necessary for just a shadow catcher... $\endgroup$
    – Chris
    Jun 20 at 8:34
  • $\begingroup$ so how do I imitate grass? just like in the hdri $\endgroup$
    – Aman Kumar
    Jun 20 at 8:35
  • $\begingroup$ But why do you want to imitate it? The shadow catcher just shows the shadow. Nothing else. $\endgroup$
    – Chris
    Jun 20 at 8:42
  • 1
    $\begingroup$ @Chris The shadow catcher should have the shape of the corresponding object of the real footage. If that is a pane, fine. If that plane is a bi bumpy, one may want to add some geometry and bumps to the catcher. Here, it has grass onit and a plane shadow may look unrealistic. However, one would need correct grass, not just some similar grass for perfection $\endgroup$ Jun 21 at 0:24
2
$\begingroup$

Not enough rep to comment, so replying ;) Adding to @Chris reply. Use plane as shadowcatcher as described, but also enable shadow catcher for the particle source object?

$\endgroup$
1
  • 1
    $\begingroup$ OP doesn't use object for grass just "Hair Shape" $\endgroup$
    – vklidu
    Jun 20 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.