-1
$\begingroup$

I have two Blender files: cloth_settles.blend and cloth_doesnt_settle.blend.

Both files use the same rigged model. Both files use the same parameters for their dress simulation as well as their collision object parameters.

Both files contain similar (but not exact) dresses, initially created with the Simply Cloth Pro add-on.

However, their behavior -- when applying a cloth simulation -- could not be any more different. This video demonstrates the problem:

https://youtu.be/-RK4Wk9QGi8

I cannot figure out why the one dress sits normally while the other one expands like a hot air balloon.

Here are the files:

cloth_settles.blend

cloth_doesnt_settle.blend

It seems that I got lucky only once with the cloth properly settling. All of the other times I tried (and I've tried a lot, always starting with the same previously-created base file), I get the hot air balloon effect.

Does anyone have any idea what's going on? I've been hammering away at this for a week but with no progress :(

$\endgroup$
3
  • $\begingroup$ you blend links don't work $\endgroup$ – Chris Jun 18 at 5:46
  • 1
    $\begingroup$ Check the directions of your Normals on both model and dress. $\endgroup$ – Rich Sedman Jun 18 at 6:34
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ – Duarte Farrajota Ramos Jun 18 at 10:46
1
$\begingroup$

I figured out why this happened. In the cloth_doesnt_settle.blend file, the dress's object collision distance setting is set to a much higher distance than the cloth_settles.blend file. You can see that value if you select the dress and go to the Physics Property tab -> Cloth -> Object Collisions -> Distance.

The Simply Cloth Pro add-on appears to have only one way binding for some (maybe all?) of its parameters it shares with Blender. So when I select the dress and go to Simply Cloth Pro -> Cloth Parameter -> Object Collision Distance and change that parameter, it changes the parameter in Blender when I go to the Physics Property tab -> Cloth -> Object Collisions -> Distance.

However, when I go to the Physics Property tab -> Cloth -> Object Collisions -> Distance and change that parameter, the equivalent parameter in Simply Cloth Pro does not change...misleading me and making me think that my object collision distance is something that it's not.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.