1
$\begingroup$

Drops of water are applied to this apple, which are themselves transparent (you can see through). The problem is that the drops do not reflect the surface of the apple and thus behave like a separate sight.

enter image description here

Properties / settings

  • Transition = 1, roughness = 0
  • Screen Sapace Refraction (material and rendering properties)
  • radiation calculation are activated.

Does anyone have any idea why the drops don't reflect the surface?

$\endgroup$
2
  • $\begingroup$ Can you post a picture of it in rendered mode instead of material preview? $\endgroup$
    – Clobro
    Jun 16 at 23:26
  • $\begingroup$ In the Material panel, under Settings, have you chosen Blend Mode > Alpha Blend? $\endgroup$
    – moonboots
    Jun 17 at 6:39
0
$\begingroup$

You are in material preview mode. modes Material preview mode uses the EEVEE render engine, but disables shadows for quick, viewport rendering. EEVEE fakes refraction using the world background.

To achieve realistic refraction in your final render, you can either use more expensive faking via screen space refraction (a 2D effect for EEVEE that can be enabled in render properties), or use the Cycles render engine instead. Note that your choice of render engine between these two will not alter the material preview view from using downsized EEVEE rendering. Refraction will always be faked there.

$\endgroup$
0
$\begingroup$

Found the bug! In this mode (shading), Screen Space Refraction of the apple must not be enabled in the material settings. It only has to be enabled in the material properties of the water droplets.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.