2
$\begingroup$

I'm trying the new line art modifier and other than a few z-fighting issues it works great! Problem is when I render it looks horrid:

Viewport render: Viewport render

Actual render in eevee: Actual render in eevee

I have no idea what could be causing this, I checked and there aren't any hidden objects that would be visible in the render but not in the viewport, either way I'll link the .blend here: https://pasteall.org/blend/75af7acbee85431daea7987a7b17eaa3

$\endgroup$
2
  • $\begingroup$ That looks like it might be z-fighting. Do you have "In Front" checked in the View Port display? I don't know why that's what controls the setting in renders, but it does. $\endgroup$
    – jwrush
    Jul 6 at 7:37
  • $\begingroup$ Whoops you posted a blend file and I didn't see, I'm a dork. I'll go ahead and check. $\endgroup$
    – jwrush
    Jul 6 at 7:39
3
$\begingroup$

The artifacts in the render are the result of Z-fighting between the strokes and meshes and it's just by chance you see the whole strokes in the viewport and not in the render. Z-fighting behavior is inconsistent.

To fix this, set the In Front setting under the Viewport Display heading of the Object Properties.

Picture of the Viewport Display ui with In Front checked

I don't know why this controls how the grease pencil strokes work in the render, but it does. I've found that I always turn this on with the Line Art modifier, actually. It seems like it's always needed if the objects are going to be visible at all, because otherwise you get z-fighting behavior.

After setting it in your blend file, I render your picture like this:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.