0
$\begingroup$

Hi i have a pretty nice render in the viewport but when i turning on the scene world check it's differ from the viewport (obviously, im copied the default hdri map from the blender folder (night.exr) i tried to edit the settings but they are not change anything help pls.

What render i need

what render i have

$\endgroup$
15
  • $\begingroup$ Does this answer your question? Render looks way different from viewport render mode. How can I fix this? $\endgroup$ – brockmann Jun 16 at 9:43
  • $\begingroup$ I guess you are trying to use an Image Texture node instead of an Enviroment Texture node, recommend follow the steps in the link above and see whether that fixes the lighting. $\endgroup$ – brockmann Jun 16 at 9:46
  • $\begingroup$ Im already using the environment texture node $\endgroup$ – Someone12512 Jun 16 at 9:55
  • $\begingroup$ Cool. However, as it stands we can only guess what you're doing wrong. Did you follow the guide? blender.stackexchange.com/a/179977/31447 Still nothing? Otherwise I'd suggest share your blend without the model, preferably using: blend-exchange.com $\endgroup$ – brockmann Jun 16 at 10:02
  • 1
    $\begingroup$ As you might see by now, impossible to figure out without a screenshot of your world shader or the blend file. I recommend put more effort into your questions, remember that only you have access to your scene, only you know your exact setup, settings and what steps you took to arrive where your are now: blender.stackexchange.com/help/how-to-ask $\endgroup$ – brockmann Jun 16 at 10:51
0
$\begingroup$

Thank You for sharing the blend file @someone12512 This is what I found

1. Rendering just as is, this is how it looks like as you might already know enter image description here

This is your world node settings, as you set it up enter image description here

2. This is what it looks like when I changed the settings enter image description here

This is what I changed enter image description here

So, I guess the problem was with the volume node connected to the world You can try different values or even create a cube and let it be the volume, idk how that could change things... But this is what I found Hope it helps

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.