0
$\begingroup$

I was just wondering if anybody knew how I could fix the shading issues and the artefacts on my model in a non distractive way.

What I have tried: I have tried moving around some vertices (which most of the time makes the curvature of the model uneven); combining some vertices which most of the time didn't work; I have tried moving around the modifier stack which did work on some of the artefacts; I have applied the harden normals in the bevel modifier; Its not the lattice as I have set the area in which it affects to a vertex group which is not close to where this issue is occurring; I have shaded smooth, set the auto smooth to true and the set angle to 30°.

If you have any idea on how to fix please let me know, Thanks.

Artefacts and strange shading issues on my model Wireframe view of the model

$\endgroup$
3
  • $\begingroup$ Hello, maybe show your wireframe. Also, do you absolutely want to keep all the modifiers? $\endgroup$
    – moonboots
    Jun 15, 2021 at 7:17
  • $\begingroup$ Ideally I would like to keep most of the modifiers. The wireframe looks fine from what I can see. @moonboots $\endgroup$ Jun 15, 2021 at 7:25
  • $\begingroup$ Actually I think in your second screenshot the wireframe doesn't look fine... would you mind showing it without the Subdivision Surface modifier enabled? $\endgroup$ Jun 15, 2021 at 8:47

1 Answer 1

1
$\begingroup$

Your topology is not good, try to avoid ngons, they tend to create artifacts, for example try this topology:

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you for your time and effort going into making a model. Re-topologized my model, and it worked! I remember also that when using a deform modifier it is best to have quads. @moonboots $\endgroup$ Jun 28, 2021 at 9:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .