1
$\begingroup$

I can't seem to get the tool to work. I want to have the mesh extrude inwards like in the last picture (taken from a tutorial) . But it just warps and moves in a random direction (second picture). It does work sometimes however in some cases (first picture)

Is there a setting I need to change?

Thanks so much for your time and help!! enter image description here

enter image description here

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ I don't think that you can extrude vertices and edges along their normals (which would be defined by the faces they are part of), in the video you show he extrudes and scale down right away (S), it's not an extrusion along normals (even if it gives the same result) $\endgroup$ – moonboots Jun 11 at 7:22
  • $\begingroup$ Thanks for your help I managed to get it working! so I selected the edges (2 on keyboard) then pressed extrude (with normals selected) then pressed s (like you said) and it worked!! thanks a million $\endgroup$ – salvador Jun 11 at 8:09
2
$\begingroup$

That's odd.. your tool icon is showing 'Extrude along Normals', but your F9 'Adjust Last Operation' panel is showing 'Extrude and Move'. If I invoke the tool in 2.92 or 2.93, this is what I see...

enter image description here

.. 'Extrude Region and Shrink / Fatten', which is what you want. And you're using 2.93.0.

The AltE > 'Extrude along Normals' shortcut option is not available for edges, but is for faces, which, IMO, is inconsistent, and needs fixing.

TLDR; Shortcut users would probably E Extrude, + Right-Click : Drop the extrusion in place, + AltS Shrink / Fatten, as represented in this illustrated version of the F9 panel.

Taking @moonboots comment into account, note that edge (vertex) normals are not the same as face normals. If you want a perpendicular extrusion, the last move would be S Scale, not Alt S, along normals. The Pivot would have to be set to scale towards the center of the loop.

$\endgroup$
2
  • 1
    $\begingroup$ I managed to get it working! so I selected the edges (2 on keyboard) then pressed extrude (with normals selected) then pressed s (like you and moon boots said) and it worked!! thanks a million. its my second day using the program so I just wanted to get a good understanding of the basics. Thanks Robin!! $\endgroup$ – salvador Jun 11 at 8:11
  • $\begingroup$ If so, please consider to accept the answer @salvador How this site works: blender.stackexchange.com/tour $\endgroup$ – brockmann Jun 11 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.