0
$\begingroup$

I'm trying to create a transparent water texture in eevee but when I set the roughness to zero using the principled shader the object becomes pitch black.

Here it is set to a roughness of 0.03. roughness 0.03

And here when it is set to 0. roughness 0

Is there some way to fix this or do I just set it to a value between 0 and 1?

edit: here is the node setup.

Node setup

late edit: I know this is late but the preview sphere in the shading workspace is also pitch black and this appears in all my files, both new and old. The preview sphere used to be reflective with the hdr background but now not even putting in a new hdr background doesn't change it.

Material Preview Sphere

$\endgroup$
7
  • 1
    $\begingroup$ That isn’t supposed to happen. Can you add screenshots of your node setup? $\endgroup$
    – TheLabCat
    Commented Jun 7, 2021 at 22:17
  • $\begingroup$ I've added the node setup to the post. $\endgroup$ Commented Jun 8, 2021 at 1:10
  • $\begingroup$ Hmm… highly unusual and exotic node setup there… nope. 😉☺️ Are all other settings in the scene default? $\endgroup$
    – TheLabCat
    Commented Jun 8, 2021 at 1:15
  • $\begingroup$ can you add your blend file? blend-exchange.com $\endgroup$
    – Chris
    Commented Jun 8, 2021 at 4:55
  • $\begingroup$ I added a late update to the post. I think the sphere may have something to do with the issue. $\endgroup$ Commented Jul 1, 2021 at 15:48

1 Answer 1

1
$\begingroup$
  1. Set 0.5 for alpha
  2. Transmission to 0
  3. Under material > Setting > Blend set to alpha hased or blend.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .