0
$\begingroup$

I'm trying to export a tree with an armature animation in Blender 2.93 to the glTF format but the animation doesn't seem to work. I'm using the default Sapling Tree Gen settings with Armature > Use Armature and Animation > Armature Animation. However, when I export to glTF and try to view it here https://gltf-viewer.donmccurdy.com/ the animation is missing. There's just a bunch of notes about empty nodes.

I've tried converting the curve to a mesh and re-parenting to the armature but same result. I'm struggling to understand how the animation data is stored and what might be the problem.

Ultimately, I'm just trying to export the tree with the animation to three.js and saw that glTF is the way to go if I can just get the animation working.

Edit: The glTF viewer has a validator that does complain about skinned mesh issues such as the skinned mesh not being the root node and transformations from the parent will be ignored. However, you have to parent the mesh to the armature for the animation to work so I'm not sure how to get around that.

I also created a test animation with some cubes and that seems to work and playback just fine.

$\endgroup$
2
  • $\begingroup$ May have to do with the fact that the tree is a curve. Try converting it to mash, maybe? $\endgroup$ – ZargulTheWizard Jun 7 at 22:35
  • $\begingroup$ I did try that and then re-parented it to the armature but no luck $\endgroup$ – Dylan Jun 8 at 5:25
0
$\begingroup$

I was able to fix this by both converting the curve to a mesh for the tree and then baking the armature animation before exporting. I haven't tried with the leaves yet but I imagine those will work as well.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.