5
$\begingroup$

Maybe I do something wrong, but I read multiple posts about it and looked into different videos. I should do it right but it's just not working.

I want to have a plane that just catches the shadow of my basketball. I enabled Shadow Catcher in the Visibility tab of the plane, but the plane is still visible.

Is something set up wrong in my scene? Or is it bugged somehow?

I'm using blender on windows if this is relevant.

enter image description here

$\endgroup$
2
  • $\begingroup$ What version of blender are u using? Shadow catcher doesn't work with cycles-x $\endgroup$
    – Sanbaldo
    Jun 6, 2021 at 14:55
  • 2
    $\begingroup$ as below, check that under Render Properties > Film, Transparent check is checked. $\endgroup$
    – Sanbaldo
    Jun 6, 2021 at 15:09

2 Answers 2

4
$\begingroup$

it works, in 3.0.0 alpha too.

Here is the result:

enter image description here

I made the cube smaller so you don't see too much shadow of the cube on the plane, because else you think you see the plane and not the shadow of the cube on the plane.

Go to render properties -> Film -> Check transparent

enter image description here

UPDATE: additional answer to your question in comment:

to remove the shadow from the plane which is there because of the cube, select the cube and uncheck: shadow in ray visibility

enter image description here

then you get:

enter image description here

$\endgroup$
4
  • $\begingroup$ Oh wow, thank you. I feel dumb now. It's not the actual plane that I see, it's the big shadow of my cube... $\endgroup$
    – jona
    Jun 6, 2021 at 15:35
  • $\begingroup$ Don’t feel dumb. We all started some time ago with Blender and learnt. That’s normal. Learning is a process ;) $\endgroup$
    – Chris
    Jun 6, 2021 at 15:45
  • $\begingroup$ Thanks. One more quick question (maybe I should open another one for this). How can I remove the shadow of the cube on the ground and only display it on the ball? In my original file there is an image plane in front which already got the shadows on the ground. I just need those shadows on the basketball. $\endgroup$
    – jona
    Jun 6, 2021 at 16:11
  • 1
    $\begingroup$ i updated my answer...just scroll down. It is the "shadow" checkbox, which you have to uncheck for the cube $\endgroup$
    – Chris
    Jun 6, 2021 at 17:52
2
$\begingroup$

Your shadow catcher is working as expected, you just need to turn on Transparency under Render properties > Film > Transparent.

If you don't want or need Transparency and you want the background color to render, you need to make the plane bigger, because right now, your plane is as big as your shadows, the shadows reach the border of the plane and you see the shape of the plane because of that

enter image description here

enter image description here

$\endgroup$
1
  • $\begingroup$ Thank you. That also solved my problem. But Chris was faster :-) $\endgroup$
    – jona
    Jun 6, 2021 at 16:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .