i made hair and UV unwrapped. Now i wanna Texture paint. The problem i am encountering is that if i paint in the 3D Viewport editor (Texture Paint) then the paint strokes are applied to the back portion as well. From what i am understanding is that brush paints on everything in its field not taking into account the front and back of the hair object. Let me attach an image to explain what i am saying.enter image description here

The red portion is where i painted with brush in the 3D Viewport (Texture Paint) window but if you look at the UV map in the Image editor, i highlighted with yellow, the unintended color, it is the back of the hair and it is painted as well.

Now you can paint in the image editor where it is a 2D image and this problem will not occur but i wanna paint in the 3D Viewport.

I am not experienced with the Texture paint features. Please tell me if there is a way around with the help of some masking, some option or any means which can make me enable to paint in the Viewport window such that the back portion of the object is not painted. Any help would be appreciated.


1 Answer 1


Check to see if 'Occlude' and 'Backface Culling' are turned off in the Options tab in the tool settings for your paint brush. With them off, I can paint through my object. enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .