0
$\begingroup$

I'm fairly new to Blender. Learning a lot from tutorials. Just updated from 2.92 to 2.93. Researched this problem, but can't find a solution. It seems like it should be a very simple function, but it won't cooperate.

Attempting to add a texture image to an anvil for a tutorial. For some reason, the texture is not being applied, even when Blender looks like it should be working properly. All I'm seeing is the same default white, ceramic looking texture, no matter what I do. Following the exact same steps as every Image Texture video that I've watched.

Tried the Find Missing File function with no success.

Tried several different file types (JPG, TIF, PNG). Tried Specular vs Metalness. None of them are being applied properly.

Including screenshots. Any help would be appreciated.

Node Image Purple Anvil [TIF Texture][1]

PNG Texture

JPG Texture

$\endgroup$
3
  • $\begingroup$ Hello and welcome, do you have a base color texture, one called base color or albedo? And is there any reason to have the specular connected to the color? Or is it just part of the tests that you are doing? Specular is just black, Grey and white image. $\endgroup$
    – Emir
    Jun 4 '21 at 0:37
  • 1
    $\begingroup$ If you want a quick way to make sure it's not some project setting that's messed up, try opening a second instance of blender, and literally copy (Ctrl+C) and paste (Ctrl+V) your object from one project to the other. Are the textures visible in the new file? Is the image texture still connected in the shading editor after the copy? $\endgroup$ Jun 4 '21 at 1:48
  • $\begingroup$ Emir - The textures are from Poliigon. Used them before with no problems. The files are labeled Specular/Metalness. The actual textures vary depending on the actual texture makeup. I've attempted to use textures from both the Specular and Metalness zip files. Christopher - I've used textures from Poliigon before with no issues. This is a completely new problem to something that I've done before with no issues. When I have time, I can try the textures on a different project file, but for the moment, I can't find any logical reason as to why it's not showing up. $\endgroup$
    – Rebel S
    Jun 4 '21 at 15:58
-1
$\begingroup$

I opened the file manually from the folder icon, from the start. Selected the file directly from the file location. First time using the "Report Missing Files". Came up with this error message. It's not making any sense, because I selected the file location manually. I'm looking right at the texture file in that location. I'll attempt to apply a texture to a different project, but I can't find any logical reason for this error.

Update: I did change the file name to Heavy001Specular/SPECULAR, so I have no idea why it's still looking for the old file name. Even after I manually updated the file path.

Update 2: I opened a new project with the basic cube. I was able to apply different textures from the Specular/Metalness files with no problems. Is there some sort of corruption in my Anvil project file?

Update 3: I opened up a previous save file for the Anvil project, for a less finished stage of the project, and the textures applied perfectly fine. It seems like something happened in between project files?

In the final Anvil project file, the Preview window shows the correct texture, but the actual Render doesn't show the texture at all. Simply a white, ceramic look.

Report Missing Files

$\endgroup$
2
  • $\begingroup$ You could edit your question instead of using the answers section to update the question $\endgroup$
    – Emir
    Jun 4 '21 at 19:18
  • $\begingroup$ I was trying to Add a Comment in response to Marty Fouts. I've used forums before. The format here is clunky. $\endgroup$
    – Rebel S
    Jun 5 '21 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.