2
$\begingroup$

Left model is in material-preview-mode, right model is in solid-mode:

enter image description here

My main problem is that I can't get my chess texture to appear on the material so that it looks the same in solid-mode and material-preview-mode. I am a total beginner in Blender. Do I need to change anything regarding UV mapping? Why does the texture change so much while in the material-preview-mode?

$\endgroup$
1
$\begingroup$

I assume that you are talking about using the Texture color mode in the Solid viewport shading settings:

This mode is not very sophisticated. It works like this:

  • If you have an active image texture node in your object’s material, the viewport will use it for shading.

  • The texture is mapped using the active UV map for the object.

  • All other aspects of the material are ignored.

This means that if you use nodes to combine information from multiple textures or to alter the texture mapping in any way, those details will not be reflected in Solid mode. This makes the Texture color mode not particularly useful for all but the simplest of materials.

Generally, I recommend not bothering with textured display in Solid mode. Just use the Material Preview mode to get a textured preview of your model. That’s what it’s there for.

$\endgroup$
2
  • $\begingroup$ The problem is that the texture should look like it is shown in solid viewport shading. I use the texture color mode that you mention. I just wanted to know why the texture changes completely when I switch to material-preview-mode. $\endgroup$ – Dominik Rifert Jun 3 at 8:56
  • $\begingroup$ @DominikRifert It is impossible to know what could be causing your texture mapping issues without seeing the material settings you are using for that object. Consider asking a new question about the texture mapping issues specifically, and include screenshots of both the material nodes and your UV map. You can also consider uploading your .blend file to pasteall.org/blend to make it easier for people to debug. $\endgroup$ – Alexis King Jun 3 at 17:54
-1
$\begingroup$

If you wish to have a shadeless view of textures.

Use the material preview view instead of the rendered view.

To my understanding, there is no way for textures to show-up while in solid view.

enter image description here

$\endgroup$
2
  • $\begingroup$ This is not true—you can use the Texture color mode to get limited textured shading in Solid mode, as I explain in my answer. $\endgroup$ – Alexis King Jun 2 at 19:50
  • $\begingroup$ You're absolutely right! The author said "textures" and I was thinking about it in technical, image terms, not color terms. $\endgroup$ – RandomPanda Jun 2 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.