0
$\begingroup$

So I am following Blender Guru's donut tutorial. I want the sprinkles to be on top. I painted only on the top but then it's where the sprinkles are not so I painted on the sides. Is this how it's supposed to work? and also how do I keep the sprinkles on top of the donut. There is one rogue sprinkle in the second image.

enter image description here

enter image description here

$\endgroup$
7
  • $\begingroup$ No, that is not how it supposed to work. I’m not sure how you did this. The rogue sprinkle is probably because some vertex over there as a weight that allows sprinkles, but the subdivision surface modifier moves it, so the sprinkle appears on the side of the donut. Try putting the sprinkle modifier after the subdivision surface modifier. $\endgroup$ – TheLabCat Jun 1 at 12:22
  • $\begingroup$ Thank you for your response. I'm a complete beginner. Where do I do that? $\endgroup$ – Patrick Kent Oaferina Jun 1 at 12:55
  • $\begingroup$ In the modifiers tab of the properties editor. Didn’t you put a subdivision surface modifier on the icing? Well, anyway, right now you’re in the particles settings tab of the properties editor, and the modifiers tab is right above it. The blue wrench. $\endgroup$ – TheLabCat Jun 1 at 13:00
  • $\begingroup$ I did put a subdivision surface modifier but I clicked apply on it and it's long gone. I only have the particle settings on the modifier tab. $\endgroup$ – Patrick Kent Oaferina Jun 1 at 13:07
  • $\begingroup$ OK. Well, I really don’t know what’s causing this, especially the fact that the vertices are appearing on the area with zero weight instead of the other way around. Can you provide your blend file? $\endgroup$ – TheLabCat Jun 1 at 13:14
1
$\begingroup$

You've inverted the vertex group density effect with the <-> button:

enter image description here

$\endgroup$
5
  • $\begingroup$ This fixed the problem! thank you so much! $\endgroup$ – Patrick Kent Oaferina Jun 1 at 14:32
  • $\begingroup$ Now how do I get rid of the rogue sprinkles? $\endgroup$ – Patrick Kent Oaferina Jun 1 at 14:41
  • $\begingroup$ you have also painted underneath so you need to correct the weight paint underneath as well $\endgroup$ – moonboots Jun 1 at 14:55
  • $\begingroup$ how do I do that? $\endgroup$ – Patrick Kent Oaferina Jun 1 at 15:26
  • $\begingroup$ you need to weight paint the same way, to subtract weight, once in Weight Paint mode, in the N panel > Tool > Brush Settings > Blend > Choose Subtract, and on the top header menu of the 3D view window, make sure your Weight value is at 1 $\endgroup$ – moonboots Jun 1 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.