0
$\begingroup$

I'm using the Molecular Script Addon. I have particles falling from a disk (the emitter) onto ice-cream. My goal is for the particles to stick to the ice-cream and to not intersect each other. That works fine. My only problem is that when I turn on "Activate Self Collision" (to avoid intersecting particles), some of the particles stop falling and hover above the ice-cream before the end of the simulation, they do not appear to have collided with other particles. If I turn off "Activate Self Collision", the problem is solved, they all fall onto the ice-cream, but then some intersect each other. How can I have both ? My collision settings in the addon:

enter image description here

If I decrease Damping, the particles hover less but many fly away when they collide with each other. Difficult to find the sweet spot. Still not clear why some stop falling before they reach the target.

edit 1.6: adding .blend file link to illustrate issue. If you start the Molecular script (select the disc and particles property), you will see that around step 100, some smarties hover on top of ice-cream and stay there. If you change damping down to 0.5, it corrects the problem partly, but many smarties fly away. https://drive.google.com/file/d/1gUN_rhggJo38pTL0vtQsyQNBow6mVY6x/view?usp=sharing

$\endgroup$
2

1 Answer 1

0
$\begingroup$

after unchecking size deflect and changing your settings to this:

enter image description here

i got this result (at frame 68):

enter image description here

...but unfortunately they intersect :(

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.