0
$\begingroup$

Hi Guys Im pretty much new to Blender and been following some tutorials and other stuff and I came into this issue and I am hoping for some help.

As seen in photos, when rendering an image, the windows are reflecting (or I should just say representing an image of what is behind the object) and I am wondering what could be the issue.

enter image description here enter image description here enter image description here

$\endgroup$
4
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    May 31, 2021 at 7:43
  • $\begingroup$ Im so sorry for the delay Im really new to this file.io/drnR3UjVrdg9 $\endgroup$
    – LegendMask
    May 31, 2021 at 10:29
  • $\begingroup$ please - before uploading - choose File -> External data -> pack all into blend .Then upload again. Thanks $\endgroup$
    – Chris
    May 31, 2021 at 10:58
  • $\begingroup$ Thank you... I did as per your instruction file.io/dBJ9sqsPPFp2 $\endgroup$
    – LegendMask
    May 31, 2021 at 11:41

2 Answers 2

3
$\begingroup$

To make a material glass-like, Eevee requires some non-default values to be set.

If your main material shader is a Principled BSDF, you need to set the "alpha" value quite low (or, a bit more advanced, use a "Fresnel"-Input). If your main material shader is "Glass", it should be transparent, depending on the angle of view.

Then, you will have to set "Blend Mode" and "Shadow Mode" to anything other than "Opaque" (like shown in the picture". This will let Eevee know, that you actually intend the material to be transparent. enter image description here

Edit: Unfortunately, I could not access original blendfile at the link given above anymore. Blendfiles can be uploaded to https://blend-exchange.com in order to stay accessible.

$\endgroup$
4
  • $\begingroup$ I tried to save the embarrassment by not asking this following question but I couldnt... but are we talking about the " Material Settings" of the glass? imgur.com/a/ZrkLw8x $\endgroup$
    – LegendMask
    May 31, 2021 at 9:19
  • $\begingroup$ Just want to clarify as well, I have not changed anything on the glass material settings... and that the glass on the door slides are the one from the Blender addon of archimesh "Panel Window" $\endgroup$
    – LegendMask
    May 31, 2021 at 9:33
  • 2
    $\begingroup$ @haarigertroll. There is a valid answer buried here somewhere, but it needs some work. Could you please rephrase your post so it reads more like a set of instructions, rather than a list of questions? $\endgroup$ May 31, 2021 at 11:26
  • $\begingroup$ @haarigertroll... you are the MVP thank you so much, after some trials and errors I tried to start a new material and approach it with your suggestion and it worked :) Thank you so much and you have a wonderful day $\endgroup$
    – LegendMask
    Jun 2, 2021 at 3:55
0
$\begingroup$

if you want less transparency and more reflection, you can just increase this value here (the fac value where the glossy output comes in):

enter image description here

then you can get something like this: (it's less transparent and more reflective)

enter image description here

if you set it to 1 you get full reflective:

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Thanks you Chris for your help I learned something new from your answer, although it didn't solve my problem but never the less I am trying to learn as much as I can :) However, my problem was solved by changing my render engine from "Eevee" to Cycles in case someone comes into this issue in the future. Really appreciate your help to everyone who answered.... till my next question you all stay safe and have a wonderful day :) $\endgroup$
    – LegendMask
    May 31, 2021 at 15:12
  • $\begingroup$ @LegendMask: If it works with cycles the way you intended, you may want to take another look at my answer, to find out how it will work with EEVEE as well! $\endgroup$ May 31, 2021 at 18:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .