0
$\begingroup$

I have import the DXF file in blender. The walls have 6 inch thickness in the CAD file. And when i imported in Blender the scale looks wrong.

DXF file

enter image description here

Note : I do not want to scale down the mesh and adjust in Blender

Any perfect way to import the DXF file with exact measurements. Thanks

$\endgroup$
4
  • $\begingroup$ How did you import the DWG? $\endgroup$ – mugnozzo May 30 at 15:08
  • $\begingroup$ @mugnozzo sorry it was DXF i have mention DWG. File-> import-> DWG and click $\endgroup$ – atek May 30 at 15:50
  • $\begingroup$ It looks to me like the DXF Importer is broken. Somewhat broken in 2.79 and really broken in 2.83 (and up). $\endgroup$ – Ron Jensen May 30 at 17:00
  • $\begingroup$ I guess I should elaborate: Scaling of the DXF does not affect the font size like it should, and in 2.8 and up it is not possible to import the DXF centered, checking that box throws a Python error $\endgroup$ – Ron Jensen May 30 at 17:03
1
$\begingroup$

This is a far from perfect answer, and ignores "I do not want to scale down the mesh and adjust in Blender." But it presents a method that should work reasonably well.

  1. There is a bug in the Blender DXF importer (0.9.6) created by the changes between Blender 2.79 and 2.8x. There is a simple fix, though. Edit the file do.py found in the addons folder. For example:

C:\Program Files\Blender Foundation\Blender 2.92\2.92\scripts\addons\io_import_dxf\dxfimport\do.py

Change line 1400 from:

      bpy.context.screen.scene = scene

to

      bpy.context.window.scene = scene
  1. Import the .dxf file making sure to check the "Center geometry to scene" button in the merge options.

  2. With all the elements selected press s to enter scale mode and then type 0.0254 to scale the objects to the exact size. This number is the conversion factor from inches, your DXF file default, to meters, Blender's internal default.

Results screenshot Note: I didn't use snapping to do the measurement so it's off a little bit.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.