1
$\begingroup$

I an trying to figure out why blender can be super laggy and slow on my high end pc. The lagg only happens with certain objects. probably because it has a lot of vertices (248k). If I go in edit mode, the interface itself is also very slow. It takes several seconds to just change from edge selection to face selection.

I even tried to apply a decimate modifier which reduced the vertices to 24k. But even then there is hard lagg (it is a bit faster though).

To give an idea about what I mean with lagg. It can take up to 5 seconds before I see the result of action. (ex. moving a single vertices/ moving the whole object in object mode)

there are also no modifiers active when this is happening.

I have updated my drivers to the latest version.

PC-build:

  • CPU: i7-8700K CPU @ 3.70GHz
  • GPU: Nvidia GTX 1080ti
  • RAM: 32 GB
  • SSD: Samsung SSD 960 EVO 250GB (M.2.)
  • OS: Windows 10

Also opened up my project with a factory startup, but the result is the same.

blender --factory-startup

Tried enabling the sampling>simplify option, but I can't see any difference when this option is enabled.

Changing the viewport shading also has no influence on the problem.

$\endgroup$
11
  • $\begingroup$ Who manufactured your ram? $\endgroup$
    – TheLabCat
    May 30 at 14:36
  • $\begingroup$ Corsair Vengeance RGB CMR32GX4M2A2666C16 (DDR4) cpuZ-screenshot $\endgroup$
    – Luhn
    May 30 at 15:24
  • 1
    $\begingroup$ Thanks to keep thinking with the issue. I scaled the model up 30x and 80x then applied all transforms but it's still laggy :/ I do think it is an issue with the amount of vertices because there is a slight improvement after applying the decimate modifier. But I don't see why 24k vertices still give such a lagg (around 1.5s). $\endgroup$
    – Luhn
    Jun 1 at 13:57
  • 1
    $\begingroup$ The object I am testing on has 248.995 vertices / 239.993 faces / 497.986 Triangles. $\endgroup$
    – Luhn
    Jun 1 at 14:17
  • 1
    $\begingroup$ Thanks again ZargulTheWizard for giving direction in finding the issue! $\endgroup$
    – Luhn
    Jun 1 at 14:41
2
$\begingroup$

Just Found the issue, The post already covers some bullet points to check if you experience lagg. So hopefully this can be useful to others. The problem in my case was the amount of (hidden) models and materials:

So it actually had nothing to do with the object itself but with the rest of my scene (even tough objects with lower amount of vertices were still fast). I duplicate my model several times to keep a backup (if something went wrong}. Also, because I duplicated a lot of models, I had a lot of duplicated materials. I just deleted all the hidden models I didn't use anymore and deleted all the duplicated materials with the "material utilities" plugin.

This process reduces the filesize of my blend file with ~800mb. It went from 1GB to 170mb.

Steps to delete duplicate materials;

  1. merge materials by name (check this post)
  2. enable "material utilities"
  3. go into edit mode
  4. select by material (right menu, see screenshot)
  5. assign everthing that is selected to the first material
  6. remove unused materials

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Praise the Lord! By the way, the file menu Clean Up area has a Purge option that can also clean up the unnecessary mesh data blocks. 😊 $\endgroup$
    – TheLabCat
    Jun 1 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.