0
$\begingroup$

I was trying out Blender Guru's Donut tutorial and got stuck while making the cup. The plane and the donut are not visible in the Layout tab even though the visibility is set. Everything is working fine in the Modelling tab and in the rendered image, so I'm sure it's a silly error which made this happen. I am not on Local view and I tried Alt + H, does not work. Blender version 2.92.0

Layout view Layout Tab view

Modelling View Modelling Tab View

Here is my Blender file:

$\endgroup$
2
$\begingroup$

The 3D Viewport has some own visiblity options if you bring up the sidebar with N, where you can disable visibility for certain collections. In the Layout View they are all disabled apart from the one that holds the camera and the light. The cup and saucer only show up there because they are not in one of those collections.

Disabling the Local Collections checkbox makes Blender ignore the Viewport settings for collections and shows them according to the settings in the Outliner. By default this setting is disabled so that the Viewport always uses the Outliner settings - I don't know why it's enabled in your scene.

3d viewport options

$\endgroup$
1
  • 1
    $\begingroup$ Thanks a lot Gordon. I have no idea how I enabled it, I may have accidentally entered the keyboard shortcut. $\endgroup$ – srp888 May 30 at 14:36
0
$\begingroup$

Both the donut and sprinkles are shown as disabled in the outliner. Click the checkboxes to enable them and see if that fixes your problem.enter image description here

$\endgroup$
10
  • $\begingroup$ I tried that and updated my screenshots, it did not work. $\endgroup$ – srp888 May 30 at 9:53
  • $\begingroup$ You'll need to upload the blend file in that case so that we can see what's going on. blend-exchange.com and read the instructions there. $\endgroup$ – John Eason May 30 at 10:44
  • $\begingroup$ Yes, I uploaded the Blend file now. $\endgroup$ – srp888 May 30 at 10:46
  • $\begingroup$ Ok. It's now appeared so I'll have a look. $\endgroup$ – John Eason May 30 at 10:48
  • $\begingroup$ I can't explain that one, but it has to be something to do with a setting in the UI. If you load Blender, choose File > Open and then uncheck Load UI via the gear wheel at the top right of the file dialog before clicking Open, it loads correctly and is visible both in layout and modelling view. However, if you just load the file normally it displays the problem you've seen! The only thing I can suggest is loading it that way then immediately saving it. That should save the settings correctly and sort the problem. $\endgroup$ – John Eason May 30 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.