0
$\begingroup$

enter image description hereenter image description here

I am watching Blender Guru's tutorial and I am trying to add color to this liquid but for some reason only a little bit of color is showing and it is not changing the full thing. And if I go into it from top view the color wont change at all. Any way to fix this?

$\endgroup$
6
  • $\begingroup$ Please add your blend file to your question. (Grab the URL of the question. Go to blend-exchange.com. Select the blend file. Add the url of the question. Grab the url that results. Go back to the question and edit it. Add the new url to the bottom of the post.) $\endgroup$ May 29, 2021 at 19:58
  • $\begingroup$ Can you add a screenshot of your node set up for the liquid material? $\endgroup$
    – TheLabCat
    May 29, 2021 at 21:03
  • $\begingroup$ @ZargulTheWizard here you go $\endgroup$ May 30, 2021 at 4:33
  • $\begingroup$ Ok. That’s better. Firstly, your absorption material is the wrong color. It needs to be the invert of coffee, because that is the color it will absorb (I have usually had to figure that out anew every time). Secondly, why is your base color not only white, but animated? $\endgroup$
    – TheLabCat
    May 30, 2021 at 8:33
  • $\begingroup$ @ZargulTheWizard What does any of that mean and how would I fix it. $\endgroup$ May 30, 2021 at 16:37

1 Answer 1

1
$\begingroup$

your node This is the volume absorption node plugged into your output, which is correct for coffee, but the thing is you’ve got it set for the wrong color: Since it is a volume absorption node, you should set it to the invert color of coffee, such as purple, so it will leave the orange/brown light unabsorbed and visible.

The next bit, however, is incorrect: your coffee surface The base color of your material’s surface should be brown, the actual color of the coffee. Here it is white. To make sure the volume shader and the surface shader stay synchronized, I might recommend using a single color input node, setting it to coffee is real color, piping its output into the base color of this principled BSDF node, and then again piping the color node’s output through a color invert node before putting it into the volume absorption node. But meanwhile, the property is highlighted in green, which means it’s animated. You must’ve accidentally set keyframes for it somewhere. Right click it, and choose “clear keyframes.“

As a last note, because one does not see the color of the coffee from the side of the cup, I suspect that you just created a face bridging the mouth of the cup, and assigned the coffee material to that. Volumetrics for that material will not work from the side in this case, because when the ray goes in the side of the cup, it never receives the volumetric instructions like it would if it were going through the top and thus through the coffee surface: Materials are assigned to faces, not spaces. You must do something to the sides of the cup that are covered in coffee as well. Most people just create a kind of block of coffee as a separate manifold mesh, and give it a tiny margin where it would in reality be touching the glass.

$\endgroup$
2
  • $\begingroup$ I have done most of what you have said, and it has worked however I can't find a clear keyframe button when I rightclick. The color on the side of the cup has appeared but I still cannot get the color I want. In the tutorial video I am watching he leaves the base color white and changes the color in the volume tab. But whenever I do this it does not work. And whenever I do try to do this it gives me a color that does not look like coffee at all. $\endgroup$ May 30, 2021 at 18:54
  • $\begingroup$ @ImaWeaboo I think I am ready to fall back to the old “please provide your blend file“ line, though I don’t like it. $\endgroup$
    – TheLabCat
    May 30, 2021 at 18:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .