1
$\begingroup$

I am only getting a single frame of an image sequence used in my Compositor output frames.

I am trying to create a series of images from a single background (static) and an animation (png) sequence. If I use the sequence of "anim 0884.png":

enter image description here

through "anim 1274.png"

enter image description here

, a file open seems to indicate a sequence "anim ####.png", but only seems to find a single frame (Frames set to '1'), including if I click on the Match Movie Length in the Node Item properties.

enter image description here

If I keep this setting I only get "anim 0884.png" used in all frames of the output "composite 0884.jpg" through "composite 1274.jpg". :

enter image description here

If I set the image sequence Frames=387, I only get the last frame "anim 1274.png" used in all frames:

enter image description here

What am I overlooking? I need the composites to start at frame 884 because other animation occurs frames 1-883, that is rendered separately.

UPDATE: I finally found a combination that worked for but it is not at all intuitive, and ... it ONLY works if I run it from the command line (blender -b postRenderCompositing.blend -S Scene.compositing -s 884 -e 1050 -j 10 -a), not with ctrl-F12!

enter image description here

Here is a link to a zip containing the blend file and sample data: https://www.dropbox.com/s/rucw94302txj6ce/postRenderCompositing.zip?dl=0

$\endgroup$
6
  • $\begingroup$ it's a little confusing while trying to understand your problem! Why have you set the frames value as 1 if you got 883 images? $\endgroup$
    – Nand 27
    May 29 at 7:11
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    May 29 at 9:56
  • 1
    $\begingroup$ No problem, just a little misunderstanding of how the offset works with the frame range, see my answer. $\endgroup$ May 29 at 15:54
  • $\begingroup$ Thanks @Nand. I have provided a link to zip with blend files and sample images, and edited my question with this and with a very odd setting that appears to work but is totally intuitive, and ONLY works from cmd-line!!! $\endgroup$
    – james_t
    May 29 at 21:18
  • $\begingroup$ @Chris -- I have provided a link to zip with blend files and sample images $\endgroup$
    – james_t
    May 29 at 21:19
2
$\begingroup$

EDIT: The settings in the Image Sequence node are a bit different then I epxlained before - my answer only worked because I tested it with an image sequence starting at frame #1 - while yours beings with #884. So here's how it all works together:

Your mistake is, you have set an Offset of 883 in the Image Sequence node and set your animation to render from frame 884 to 1271 (my month and year of birth :D ), while at the same time you have set Start Frame set to 1 in the Image Sequence node - but your animation starts at frame 884.

What the three values Frames, Start Frame and Offset do is the following:

  1. Frames tells Blender how many images are in that sequence
  2. Start Frame tells Blender on which frame the sequence should begin to run
  3. Offset tells Blender what to add to 1, to get the image number on the specified Start Frame

So, in order to make this work you must either render the animation from frame 884 to 1271 and make Blender believe you have 1271 images starting at frame 1, set

Frames = 1271, Start Frame = 1, Offset = 0

in the Image Sequence node. This will render on each frame the image with the same number as the frame. So image#0001 on frame 1, image#0002 on frame 2 etc. Since your image sequence starts at #0884, the frames 1-883 will stay empty and the frames will start getting rendered at frame 884. If you would have set Frames to 388, then Blender will stay at image#0388 until the end of the animation which is not what you want (because there is no image#0388).

Or the better and more correct way would be, you render your animation from 884 to 1271 and set the following values in the Image Sequence node:

Frames = 388, Start Frame = 884, Offset = 883.

This way you can set the actual number of images your sequence has, and Start Frame tells Blender on which frame you want to render the first image of your sequence. Since the first image is usually #0001, you have to enter the Offset to tell Blender you don't want to begin with image #0001, but with 1+883 i.e. image#0884.

Whatever the range of your animation might be, let's say you want an animation starting at frame 1 and ending at frame 3000 - that's not really relevant for the Image Sequence node. You can render frames 1-3000, and if you want your image sequence to begin at frame 100, then set Start Frame = 100. Blender assumes you want image#0001 on frame 100, so you need the Offset = 883 to correct that.

$\endgroup$
4
  • $\begingroup$ Thank you so much for your time and well formed answer that I will accept your answer, but I updated my question with what worked, inspired by your answer. I need to focus on your EITHER answer, because I eventually want to run existing frames 1-883 with these other animated (and composited) frames 884-1271. It turns out the numbers that work for me don't make sense, but publish my results I shall. I may switch to first rendering an AVI from PNG if it holds the alpha data, and then use MOVIE as input instead. I think there's a bug? $\endgroup$
    – james_t
    May 29 at 21:16
  • 1
    $\begingroup$ @james_t I'm sorry, I tested my answer with an image sequence that ranged from image#0001 to image#0100 - and that made my answer work for me but not for your sequence. Now I've updated and acutally when you do it like that there will be no need for senseless numbers or rendering from the command line. My new answer explains why your settings worked (although there should be no need for the command line), it's still my EITHER answer - only with offset 0, you have 883 which makes Cyclic necessary. But the OR answer is now much more correct. $\endgroup$ May 29 at 22:57
  • 1
    $\begingroup$ Eurika! Thanks! I was overthinking the Start and Offset, when in fact it is the Render Start and End frames that produce specify the correct frame numbers! $\endgroup$
    – james_t
    May 31 at 16:06
  • 1
    $\begingroup$ You're welcome :) $\endgroup$ May 31 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.