1
$\begingroup$

Recently I followed some tutorials and made a project in Blender.
It's just a teddy bear and a donut with a fork I found online and a cup (some from Blender Guru).
The viewport shading material preview looks fine:
viewport shading material preview

Even the viewport shading render preview looks fine:
viewport shading rendering preview

But if you render it, the teddy bear is strangely transparent. and the icing flakes are not getting rendered.

render result

You still can see a bit brown, but almost all of it is transparent, although the transparency is set to 0 and the icing flakes completely disappeared.
Is it because of the light bouncy thingy or something else?
You can find the Blender File here:

Thanks

$\endgroup$
1
  • $\begingroup$ Does it work when you render? $\endgroup$ – math May 28 at 13:52
3
$\begingroup$

This has happened to at least 3 times but seems like I don't remember it at all! it took me a little while to figure it out.

The issue with the teddy bear is that, You have not enabled show emitter in the particle's section. Hence the render shows just the hairs but not the bear which is emitting those hair particles!

enter image description here

As per the ice flakes I see a collection called sprinkles in particle selection but it seems to be deleted. the name in the particles seems like just the cached name!

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks, it worked! I copy pasted the donut from another blender file and forgot to copy the sprinkles too. $\endgroup$ – math May 28 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.