0
$\begingroup$

I'm really struggling to work this out. I've uploaded my file here:

https://drive.google.com/drive/folders/12SsWvjO9dYfF3BEPrZmdNJyiH8FAqiRd?usp=sharing

I made some curved stairs. Basically, I want the steps to stay nice and sharp, but I'd like to smooth the vertical, curved sidewalls of the staircase. Currently I can't auto-smooth because all the steps are individual pieces that are not connected. I've tried merging vertices and faces by distance, but I just cannot work out how to join them.

I hope this makes sense, and thanks in advance for any help! :)

$\endgroup$
2
  • 1
    $\begingroup$ "Currently I can't auto-smooth because all the steps are individual pieces that are not connected" - I think this is the problem. You have to join individual pieces by selecting them and pressing Ctrl+J in order to merge vertices. $\endgroup$ May 28 at 8:21
  • $\begingroup$ @MarkusvonBroady I don't know whether she changed something, but the pieces are joined...The problem is because of her geometry. She should have modeled it in a better way. $\endgroup$
    – Chris
    May 28 at 8:45
1
$\begingroup$

To get the result you want with smooth sides and better geometry there are a lot of steps necessary, but I can show you how this is achieved. For most of the following actions it's easiest or most comfortable if you use Vertex Select in Edit Mode.

  1. Select everything with A, then press X > Limited Dissolve. This gets rid of several vertices you don't need anymore.

  2. From the menu choose Mesh > Clean Up > Split Non-Planar Faces. steps1+2

  3. It's important that the side faces are split at the vertices where they bend towards the front, so make sure the Max. Angle value in the split options is set low enough so that there appear new edges between those vertices marked in the image.

  4. For the following steps you need to set the Snapping to Vertex. You can also enable the Snap Tool (the magnet symbol) or later hold Ctrl while moving things to temporarily enable snapping. steps3+4

  5. Now you have to make cuts in all front faces of each step (except for the smallest one). You do that with the Loop Cut and Slide tool. Enable it by pressing Ctrl+R, then move your mouse to one edge of the front face of the higher step behind the smallest step. Make sure you're on an edge above the small step to definitely cut the higher front face, not the backface of the small step. Click to cut the face, then slide the cut up to the corner vertex of the small step.

  6. With the Snap tool enabled (or holding Ctrl for temporary snapping if the tool is disabled) make the loop cut snap to the corner vertex and left-click to place it there. Now you have to repeat this for each following higher step. steps5+6

  7. For the following actions make sure you have Options > Auto Merge enabled. Next, select all six vertices between a smaller and a higher step that are supposed to be more or less aligned vertically (see left side). A good way to do it is to use the X-Ray or Wireframe mode, go to the Top View and select the very close vertices with Box Select or Circle Select. step7

  8. To align them all, hit S to scale, then Shift+Z to constrain scaling to X and Y axis, hit 0 to scale to zero and left-click or Return to confirm. The vertices are aligned now but kept their distance vertically. You have to repeat this for all rows of vertices where the back and front of two steps meet.

  9. After aligning all vertices like that, the Auto Merge option ensures that where two vertices shared the same location, they got merged into one. The only problem left now are the remaining inner faces that were on the backside of the steps. Deselect everything with Alt+A or double-tap A, go to the menu, Select > Select All by Trait > Interior Faces. steps8+9

  10. This selects all faces hidden inside the mesh. To delete them hit X > Delete > Faces. You can now go back to Object Mode.

  11. Switching back to Solid View everything's shaded flat. Right-click the staircase > Shade Smooth. steps10+11

  12. Now the staircase looks terrible although you have Auto Smooth enabled. The problem is you have set it to 105°, which means Blender smooths even over the sharp 90° corners. To correct this, set the value to something that is in any case below 90°, usually the default 30° are sufficient, maybe go up to 45° if that doesn't seem to be enough. Et voilà, it's finished. step12

$\endgroup$
4
  • $\begingroup$ Gordon, you are a superstar - thank you so, so much for this incredibly detailed and clear response. I managed to follow along and now my staircase looks great! What, in your opinion is the best way to learn Blender? I have been following along tutorials but I struggle to make my own ideas from scratch without running into these kind of problems. To be fair, I'm quite new to Blender but rather than following along with specific examples, I seem to need a more fundamental understanding of 3-D geometry. Any tips? :) $\endgroup$
    – TurboQuack
    May 29 at 9:44
  • $\begingroup$ @TurboQuack That's not an easy question. I guess many have some more or less working answers, but it definitely comes down to how you get along with tutorials etc. and what you want to achieve. I don't think I'm a good example, because apart from some 3D things for work and making my house to test furniture and wall paint or create objects for 3D printing for others, I'm just playing around. I do it like others solve sudokus, just for fun. Basically I watched a lot of Blender Guru tutorials, also the free CG Cookie things and a lot more. But often just watching, not doing them really. $\endgroup$ May 29 at 10:01
  • $\begingroup$ @TurboQuack Those tutorials often just show me what you can do and what functions there are or some basic things. To get more in-depth knowledge in how to achieve some things I'm playing around with lots of settings, making tests how modifiers, materials etc. work and how to improve the look of something. And when I'm stuck somewhere and don't know why something isn't working like expected I'm searching for specific tutorials on these things or use a site like this to go into details. But as I said, I'm no good example for people that want to achieve something in 3D modeling ;) $\endgroup$ May 29 at 10:06
  • $\begingroup$ Thanks Gordon, that's still really useful to know, though. It seems that many Blender "problems" are too unique and complex to formulate into an easily learnable, simplified ruleset, and that there are also usually several solutions to the same problem. I guess I will keep following relevant tutorials, while also trying to make the visualizers I imagine until I get them right. $\endgroup$
    – TurboQuack
    May 30 at 8:50
0
$\begingroup$

as others said the Geometry is not perfect but still not that bad! Try to use loop cuts to get a good geometry and also loop cuts can resolve some shading issues.

I really didn't understand how you wanted it to look but having a look at the blend gave a little insight of your problem.

enter image description here

enter image description here

if these results are what you wanted then, try using normal edit modifier on a vertex group(on just the vertical face).

I can explain in detail if you want to know!

The normal edit might not be a perfect solution for this issue but that is all I know for now!

$\endgroup$
1
  • $\begingroup$ Thanks so much, yes, that's the look I was going for. Gordon's solution above worked perfectly for me but I also appreciate your ideas. It's good to be aware of several ways to do things. $\endgroup$
    – TurboQuack
    May 29 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.