0
$\begingroup$

I started to make smoke simulation, I saw some tutorials to do that. I can see the smoke in solid view but not in render view instead I can see the color of the smoke outside the domain. I did this project in blender 2.9 Eevee. I couldn't fix the problem.

This is in solid view (https://i.stack.imgur.com/wcUbR.jpg) This is in render view (https://i.stack.imgur.com/v1FQ6.jpg)

Node setup (https://i.stack.imgur.com/FL6rj.jpg)enter image description here

Here is the blend file.

$\endgroup$
5
  • 2
    $\begingroup$ Hello, and welcome. you don't have to make a new topic for the same question. You just need to edit the original one and ask for the question to be open again $\endgroup$
    – Emir
    May 27 '21 at 12:13
  • $\begingroup$ I voted to close for Emir reason ... BTW I don't have your issue under 2.93 eevee ... it is brighter but still visible. Change background (world) color to black ... probably just display intensity? $\endgroup$
    – vklidu
    May 27 '21 at 13:53
  • $\begingroup$ I changed but smoke and fire is not inside the domain. Please help. $\endgroup$
    – Sheiman
    May 27 '21 at 14:02
  • 1
    $\begingroup$ Please ... change your original post blender.stackexchange.com/questions/223698 and ask to reopen as suggested with proper screenshots as suggested ... anyway according to your blend file - since I can't reproduce issue (fire out of domain) I can't help anyway ... try start a new file from scratch or different version of blender. $\endgroup$
    – vklidu
    May 27 '21 at 14:06
  • $\begingroup$ Instead of having users go through links and external sites please use the builtin tools to embed images in your post. See How to upload an image to a post? $\endgroup$ May 27 '21 at 16:33
1
$\begingroup$

i downloaded your blend file.

I raised the resolution division to 64 (which is already low - but 32 is too low).

I checked adaptive domain.

I tapped on "bake all".

Result (Rendered view):

enter image description here

if you want more smoke, go to shader editor and increase density:

enter image description here

then you get:

enter image description here

more density:

enter image description here

more smoke:

enter image description here

$\endgroup$
7
  • $\begingroup$ Thanks for your reply and answer. I did what you said in the answer but the fire and smoke scatters all over the render view port. I used blender 2.9 $\endgroup$
    – Sheiman
    May 28 '21 at 5:55
  • $\begingroup$ Did you try it with a newer version? $\endgroup$
    – Chris
    May 28 '21 at 7:27
  • $\begingroup$ Yes, I tried with a new version even I tried in blender 2.8. I think so there must be volumetric problem. The smoke and fire is not inside the domain in render view. This happens only for smoke and fire simulation. This problem is not found in volumetrics in lights. $\endgroup$
    – Sheiman
    May 28 '21 at 8:03
  • $\begingroup$ honestly...i never heard or read of such a problem. I am not sure but i think it could be your computer/graphic card...i just tried out with 2.83 -> works $\endgroup$
    – Chris
    May 28 '21 at 8:25
  • $\begingroup$ Hi, I think so vdb modifier not working. Is there anything to turn on? $\endgroup$
    – Sheiman
    May 29 '21 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.