0
$\begingroup$

When I switch from viewport shading solid to viewport shading render suddenly every objects disappears. Just a second before everything was perfect in render view. In just a matter of time when I came back to viewport shading render from viewport shading solid the screen got fully greyed out. I also checked several other options such as objects visibility(eye icon in right) and objects that are hidden by pressing alt + H and / key if anything is isolated. I am using blender version 2.92.100. Could someone help me out with this coz I am stuck with this.enter image description here

$\endgroup$
3
  • $\begingroup$ Do you have an AMD graphics card ? $\endgroup$
    – Gorgious
    Commented May 27, 2021 at 10:41
  • $\begingroup$ i don't see any lighting in your scene...but since this is just a screenshot...it would help if you provide your blend file. $\endgroup$
    – Chris
    Commented May 27, 2021 at 11:58
  • $\begingroup$ No I have NVIDIA RTX 2060 $\endgroup$ Commented May 28, 2021 at 6:58

2 Answers 2

1
$\begingroup$

I suppose Gorgious might be correct with his guess. If you have an AMD graphics card you might have a look at this question:

AMD GPU material is entirely gray

Since you have Overlays disabled, there will not even be an outline of selected objects visible etc.

If it's not the graphics card, check if you might have disabled the Object Types Visibility for Mesh by accident (see left side of screenshot). Or maybe you have disabled the Ray Visibility for Camera in the Object Properties (right side of screenshot), but the latter you must have done on each object that's in the scene which I doubt.

If it's none of the above providing a blend file would be better to find out what it might be. Even if there would be no light in the scene, the world background shines a dim light on the objects so there must at least be something visible. Or do all objects have only a Diffuse shader set completely to white maybe?

visibility settings

$\endgroup$
4
  • $\begingroup$ Downvoted? This might not be solution, but I don't think (quoting from the help pages) "the post contains wrong information, is poorly researched, or fails to communicate information". As long as there isn't more information in the question or a blend file there isn't much more to guess... $\endgroup$ Commented May 27, 2021 at 12:59
  • $\begingroup$ +1 I think guesses are great, because even if they don't help the OP, they might help a visitor from Google. $\endgroup$ Commented May 27, 2021 at 17:36
  • $\begingroup$ i agree! +1 for u, he probably downvoted coz he didnt have AMD xd $\endgroup$
    – Harry McKenzie
    Commented Jul 25, 2022 at 4:54
  • 1
    $\begingroup$ @HarryMcKenzie Yeah, might be - if I had known that by the time I wrote the answer... but my answer actually deals with other things apart from having AMD GPUs. $\endgroup$ Commented Jul 28, 2022 at 6:13
0
$\begingroup$

In the 3d Viewport click on menu View > View Regions > Clipping Region or use shortcut Alt+B to solve the issue

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .