0
$\begingroup$

I press Ctrl+B and create a region for Cycles to render in Blender 2.92. The border is visible in the viewport and it all looks set to go. But every time I hit F12 to start the render, Cycles ignores the region and starts rendering as it would from the full camera view. I tried everything I could think of, including disabling the camera, but nothing seems to fix it. What could I be doing wrong? Could someone help me please?

This is how I've set Cycles up for this scene.

enter image description here

And this is how I've set up the Output Properties. As you can see Render Region is ticked.

enter image description here

$\endgroup$
1
  • $\begingroup$ You have created the render region in camera view, haven't you? $\endgroup$ May 25 at 12:59
0
$\begingroup$

From Blender Manual: https://docs.blender.org/manual/en/2.92/editors/3dview/navigate/regions.html#render-region

Render Border is rendering part of your scene when you're in rendered shading mode. If you want a rendered result you'll have to set up a camera for that view.

$\endgroup$
7
  • 1
    $\begingroup$ I've updated your link. He says he's working in 2.92, not 2.79 and some of those old settings like Border in the Dimensions panel no longer exist. $\endgroup$ May 25 at 13:04
  • 1
    $\begingroup$ @GordonBrinkmann Thanks for catching that! $\endgroup$
    – Kyriakh
    May 25 at 13:10
  • $\begingroup$ @GordonBrinkmann thank you for your reply. I'm afraid I still don't understand where I'm going wrong. Do you mean that every time I want to render a new region I need to set up a camera specifically for that region? I do have Render Region ticked in the Dimensions panel, as you can see from the screenshot above, and the region I'm trying to render is within the scope of the camera I've set up. Please elaborate. BTW I'm rendering in CUDA combining a GeForce RTX 2070 SUPER graphics card and an Intel Core i9-99000K CPU @ 3.60GHz. I don't know if that's relevant in this case but here it is. $\endgroup$ May 25 at 16:46
  • $\begingroup$ @PhaedonZacharoudes No, you don't have to setup a camera each time you want to render a new region, that would be terrible :) But you have to define the render region while you are in camera view. You know, when you hit Numpad 0 and look through the camera. It's not enough that it is within the scope of the camera but you are just in navigation mode in the viewport. To really render it, you have to define it while looking through the camera. $\endgroup$ May 25 at 17:11
  • $\begingroup$ @GordonBrinkmann thank you! Pressing Num+0 did the trick! None of the videos I watched on Render Region mention this requirement so I'm very appreciative of your explanation. $\endgroup$ May 26 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.