1
$\begingroup$

I am new to Blender and I'm struggling to render texture shading. My object shows up fully texture painted in the Viewpoint Shading window, but in the Render (Cycles), it is only partially colored or completely gray (depending on my setting). Can you help me render with the same texture paint as is seen in viewpoint shading?

I am not sure if this is a node, material, or other issue. Any advice is greatly appreciated!

Blender Render Preview:

Viewpoint Shading:

Shade Node Editor:

Update: I have changed the nodes due to helpful input from @Kyriakh, however, I am still missing part of the texture. Can you help me determine why the texture isn't fully showing up?

New dolphin render:

New node connections:

$\endgroup$
3
  • $\begingroup$ You don't connect yellow and green dots in nodes directly. Try going through the BSDF node first. $\endgroup$
    – Kyriakh
    May 24, 2021 at 23:41
  • $\begingroup$ @Kyriakh Thanks for the helpful feedback! I reconnected the nodes so that the "color" (yellow) goes to the "base color" and the "subsurface color". I connected the green "BSDF" to "surface." This gave me more of the texture paint that I want, but part of the texture paint is still missing. I will post an updated photo above. Any ideas? $\endgroup$
    – user124723
    May 25, 2021 at 2:05
  • $\begingroup$ Without the file it's hard to tell, but you say the render is only partially colored or gray, do you have a screenshot of that? It would also be interesting to see the "BakedDolphin" image you have in your node setup. Does the image look correct? Your screenshots only show a preview of an image texture called "wrinkle texture.jpg" and that seems to be completely black... $\endgroup$ May 25, 2021 at 6:45

1 Answer 1

0
$\begingroup$

It looks you're having a problem with your UVs. Check your UV Maps in the 'Object Data Properties' panel. If you have multiple, try enabling the camera option for the other ones.enter image description here

If you only have 1 UV Map, then you might have to re-align your mesh UVs (You can do this in the UV Editing workspace)

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .