3
$\begingroup$

I am modeling a microphone with specific honeycomb pattern. enter image description here

I have created the honeycomb pattern using Extramesh > Honeycomb. Then applying curve modifier I made it rounded. enter image description here

With reference to the original image, I have to create holes in the body of the Mic. However, while I am using the Boolean modifier, I face some problem. Modifier doesn't cut holes in it. enter image description here

Can someone help to understand how to resolve this issue? Thanks in advance! Blend file:

$\endgroup$
4
  • $\begingroup$ Could it be that the honeycomb is not deep enough?. Another thing is to try is to cut a rectangle on the microphone and use the honeycomb as a grid $\endgroup$
    – Emir
    May 24 at 12:52
  • 1
    $\begingroup$ Please add your blend file to your question. (Grab the URL of the question. Go to blend-exchange.com. Select the blend file. Add the url of the question. Grab the url that results. Go back to the question and edit it. Add the new url to the bottom of the post.) If not, at least show us a screenshot of the Boolean modifier, as I suspect that its settings are your problem $\endgroup$ May 24 at 14:52
  • $\begingroup$ The problem is that, the smooth shading smooths every edge, even the 90°-s. You have to enable the "Auto Smooth" under the mesh properties (little green triangle on the right side). docs.blender.org/manual/en/latest/modeling/meshes/… $\endgroup$
    – FFeller
    May 24 at 16:01
  • $\begingroup$ @MartyFouts added $\endgroup$ May 28 at 6:51
5
$\begingroup$

I dont think you need a Boolean at all, here. You can just use the holes Extra Objects > Honeycomb has given you.

If you work in the flat:

enter image description here

  • Take 2 chunks of honeycomb ( to be more non-destructive, you could work under a Mirror modifier)
  • E Extrude various edge-loops, something like as shown, and scale them to 0 in the appropriate dimensions to straighten them
  • Cut some loops in the extrusions, to make the transition from hex to rectangle nice and even. I used the shipped Loop Tools add-on > Space to get an even distribution of vertices in the regions you want to be smoothly cylindrical.

Then you can give the sheet Simple Deform > Bend through 360, Weld to seal up the seam, Solidify for thickness, a Bevel modifier to put some glint in the edges, and smooth then out a bit...

enter image description here

$\endgroup$
1
  • 2
    $\begingroup$ and the master strikes back again....! :D $\endgroup$
    – Chris
    May 24 at 19:47
0
$\begingroup$

The boolean modifier is cutting through the mesh, you just can not see it. You have to hide the mesh that is cutting through the mic (in your case those circles) in the viewport and the render by clicking the eye and the camera button or going to object properties>visibility and untick show in viewport and renders. For the smoothing problem you have to enable auto smooth.enter image description hereenter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.