2
$\begingroup$

I've got a problem with rendering this scene. What I get, looks totally different compared to render view, with these options turned on, also changes in light paths, setting bounces etc. doesn't seem to affect anything. What did I do wrong? Is there something in the Render settings, Preferences, or my computer (worst option, hopefully not)?

File:

enter image description here

enter image description here

EDIT:

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$
10
  • $\begingroup$ Does this answer your question? How to use 2.8's default HDRi's in renders? $\endgroup$
    – Emir
    May 22 at 17:15
  • $\begingroup$ If you look at "Sampling" in your scene properties, you can see one difference, which is that you are using many fewer samples in the viewport. So the viewport will have more rendering artifacts (sometimes called fireflies.) Another major difference is that you are using a denoiser in your render but not in the viewport. $\endgroup$ May 22 at 17:29
  • $\begingroup$ @Emir unfortunately, no $\endgroup$
    – kuksu
    May 22 at 17:29
  • $\begingroup$ @MartyFouts thank you, I did some changed and updated the post. Deleted denoiser and also increased viewport sampling, it looks the same. All render settings attached $\endgroup$
    – kuksu
    May 22 at 17:42
  • $\begingroup$ For me it looks like you have an HDRI for the render preview, but no HDRI for the Final Render, that's why I suggested the answer to add a world HDRI. There is basically no reflection on the final other than the floor and wall $\endgroup$
    – Emir
    May 22 at 17:42
4
$\begingroup$

You have a fourth diamond, called "Diamond1" in your scene. You have it enabled for render but not for viewport shading:

Diamond1 in render but not viewport

When I disable it from the render, the two match as closely as can be expected:

disabled in render

Viewport

viewport

Render

render

The remaining difference is because there are more samples in the render than the viewport.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.