0
$\begingroup$

in Blender 2.79 I used to have a technique to make meshes have an even/homogenous distribution of vertices. I would start to increase the number of vertices (if necessary) using the "subdivide" or the "remesh" tools. Then I would apply a "remove doubles" (in 2.79, now it's called "merge by distance") with a distance that corresponds to a density I wanted.

The issue is that using the "remove double" would work pretty well in version 2.79, however in recent versions (e.g., 2.92) using the "merge by distance" tends to produce a lot of non-manifold faces.

This can be demonstrated just by using the default cube scene:

  1. Start with the default scene cube enter image description here
  2. Apply a default settings "voxel remesh" (usable from object mode, not from edit mode) enter image description here
  3. Apply a "triangulate faces" and a "shade smooth" (that will help visualise the issues in the next step) enter image description here
  4. Do a "merge by distance" at 0.2m enter image description here
  5. Deselect all and then "select all by trait" - "non-manifold"enter image description here

As it can be seen, the mesh becomes all messed up.

For comparison here is the result of the equivalent operations in 2.79: enter image description here

Is this a bug? Is there any workaround for this?

Is there a better way to achieve homogenous vertex density while maintaining manifoldness?

Thanks.

$\endgroup$
4
  • $\begingroup$ I think you want to use the "Decimate" modifier rather than "Merge by distance" $\endgroup$
    – Gorgious
    Commented May 22, 2021 at 8:51
  • $\begingroup$ The issue with "Decimate" is that it doesn't let the mesh with a homogeneous density of vertices. $\endgroup$ Commented May 22, 2021 at 9:02
  • $\begingroup$ It does appear to be a bug. Have you checked the bug data base? developer.blender.org/maniphest and query for the bug. If there doesn't seem to be anything, perhaps you could file a new bug report. wiki.blender.org/wiki/Process/Bug_Reports gives a summary of how to do that. $\endgroup$ Commented May 22, 2021 at 16:36
  • $\begingroup$ It seems that it is not a bug, as Nathan has said in a comment to my answer blender.stackexchange.com/questions/223381/… $\endgroup$ Commented May 22, 2021 at 17:37

1 Answer 1

0
$\begingroup$

Well, I think I may have found a nice way to solve my own issue using the remesh tool itself:

Using the "QuadriFlow Remesh" with the "Edge Length" mode set to the desired value, or using the "Vertex Remesh" with the "Voxel Size" set to the desired value, produces pretty and homogeneous meshes while maintaining manifoldness.

Example:

  1. Starting with a UV Sphere, which has a vertex density not so homogeneous

    enter image description here

  2. Apply a "QuadriFlow Remesh" with the "Edge Length" mode

    enter image description here

  3. The mesh gets a more homogeneous vertex density

    enter image description here

  • Using the "Vertex Remesh" with the "Voxel Size" set to the desired value

    enter image description here

  • will result in an also nice mesh:

    enter image description here

The other remesh settings, may also produce nice results.

(Anyway, I still think that the merge by distance has some kind of bug, or else it must be used carefully. Edit: it's not a bug, it's expected behavior)

$\endgroup$
1
  • 1
    $\begingroup$ Merge by distance does have to be used carefully, but it's not a bug-- it's doing exactly what it's supposed to do, merge by distance. Whether that creates non-manifold geometry or not depends on where your vertices are and what distance you choose. This was true with earlier versions' remove doubles as well-- you were probably just luckier in earlier versions. $\endgroup$
    – Nathan
    Commented May 22, 2021 at 15:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .