0
$\begingroup$

Thanks for reading this.

When rendering I get black areas using Cycles. It happens with path tracing and also branch tracing. I tried to deactivate all different light sources but problem still persists. I have checked the geometry and that seems OK too.

Blender version 2.92

I have included the blend file in the following link.

https://drive.google.com/file/d/10B9H-IZI_4YW23S_orMQxuBohhXw6plb/view?usp=sharing

Thank you very much for helping out.

enter image description hereBest regards.

enter image description here

$\endgroup$
1
$\begingroup$

Your Normal and displacements are connected in the wrong way, you need a Normal map node and a displacement Node, also your normal image needs to have a Non color on the color space.

enter image description here

$\endgroup$
3
  • $\begingroup$ Thank you so much for getting back so quickly. Really appreciated! Regards! $\endgroup$
    – Blendoo
    May 19 at 16:04
  • $\begingroup$ @Emir I'm at the phone right now so I can't download the file to check materials and textures... but is it intentional that you've plugged the Alpha output of the texture into the Color input of the Normal Map node? $\endgroup$ May 19 at 21:02
  • $\begingroup$ You are right, wrong right side screenshot, sorry I was testing the texture and did not notice the screen, I will edit that later $\endgroup$
    – Emir
    May 19 at 22:52
0
$\begingroup$

Additionally to Emir's answer, some more findings:

You have created the bunkers with the Boolean Modifier. To get a smooth result you should enable Auto Smooth and Shade Smooth (right-click the object in Object Mode)

no auto smoothNo auto smooth

with auto smooth enabledAuto smooth enabled

For the material you need to add the Normal Conversation group before the Normal Map node that you had forgotten to add. This will remove the black area as seen on Emir's screenshot at the inner of the concrete bunker.

missing nodes

You have also node groups named "NodeGroup", "NodeGroup.001", "NodeGroup.002" which all do the same as the "Normal Conversation" node does. They just use an Invert node instead of a Math Subtract node You might have accidentally duplicated the groups.

$\endgroup$
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.