1
$\begingroup$

I've added a torus and and then a cylinder to the middle of it and tried to delete the cylinder from the torus, but instead of deleting the vertices within the cylinder object, it just makes a cut through the torus.

I've tried recalculating the normals of both objects to be outside and then inside (same for each). I've deleted loose vertices (there shouldn't have been any, but the torus had a few).

I tried triangulating the large faces on the top and bottom of the cylinder.

I've made sure the cylinder overlaps the torus in the z direction by a lot.

I haven't modified either object in any way other than through their numeric parameters (scale, dimensions, etc).

I've applied all transforms.

Any insight as to why these two basic meshes created by Blender itself won't boolean difference?

enter image description here

$\endgroup$
8
  • $\begingroup$ please provide blend file $\endgroup$ – Chris May 18 at 11:38
  • $\begingroup$ by the way...is the cylinder closed? has it top and bottom face? $\endgroup$ – Chris May 18 at 11:38
  • 1
    $\begingroup$ @Chris Yes, he tried triangulating the top and bottom faces to resolve the problem. $\endgroup$ – Gordon Brinkmann May 18 at 11:49
  • $\begingroup$ ähm...maybe i am too silly to understand...do you wanna do this? [1]: i.stack.imgur.com/0o83c.png ...just works ....but i think, i misunderstood... $\endgroup$ – Chris May 18 at 12:20
  • $\begingroup$ @Chris I guess that's how it should be, but I actually had the same problem (in 2.83.5, but not in 2.92.0). $\endgroup$ – Gordon Brinkmann May 18 at 12:26
2
$\begingroup$

I've tried it with the default torus and default cylinder and got the same problem. I resolved this with several methods: moving the cylinder just a little off the center or scaling it up or down just a little. I guess the cylinder cuts exactly through the vertices of the torus and maybe Blender has some issues calculating it correctly. Also adding a Subdivision Surface modifier. Nearly everything helps except for keeping it at default.

EDIT: Well it doesn't cut exactly through the vertices becauses the objects have different resolutions. But still the edges overlap each other... I guess that's why. And just for clarification: I only have this problem in Blender 2.83.5, not in 2.92.0 or 2.93.0 Beta.

$\endgroup$
4
  • $\begingroup$ i don't understand !? make me intelligent! ;) isn't that what he wants? for me this works with default torus + cylinder: youtu.be/0SlPlVkTVz0 $\endgroup$ – Chris May 18 at 12:24
  • $\begingroup$ Maybe it is an older bug, I've added it in my answer that I can only reproduce it with 2.83.5 but not 2.92.0 (in his screenshot you see it's 2.81.16, so even older). $\endgroup$ – Gordon Brinkmann May 18 at 12:31
  • $\begingroup$ aaahhhh, ok thanks. I am not that silly, just a bit inattentive ;) $\endgroup$ – Chris May 18 at 12:57
  • $\begingroup$ so once again (as usual and always) upvote from me ;) you deserve it $\endgroup$ – Chris May 18 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.