0
$\begingroup$

I am dealing with a problem when exporting the animation I've tried to create on my own. I don't think I messed up something during the animation process, so it has to be something with the output settings. Just like with the donut tutorial (which I exported with the same settings and without any quality loss), I rendered all frames into a separate folder. Only then put them into Video Editing as "Image/Sequencer", chose all output settings, and clicked "Render Animation", as I should. In the Render environment, I see it played in high-quality, just as it should. But then, when I open the video in Windows Player, it seems like it stretches the video to default 1920x1080, whilst it's set to 500 x 500 in the output settings (same whilst animating). I checked all the output settings, but haven't found an issue regardless. I have attached some screenshots to give a clearer view of what I am talking about.

enter image description here

enter image description here

enter image description here

Animation in Windows Player

$\endgroup$
2
  • 1
    $\begingroup$ The object in the image doesn't look very stretched to me... is it really stretched to 16:9 ratio or is the player just showing the open spaces left and right in black which makes the black background of the video look like it's stretched out to the sides? $\endgroup$ – Gordon Brinkmann May 17 at 22:13
  • $\begingroup$ Yes. In file settings, it shows it is 500x500, as on the output. But yes, It looks like it stretches the resolution of a screen. I do not know what is the reason exactly. Maybe you did not spot it, but there is also a significant quality drop. So I can see pixels and noise whilst opening the animation in Windows Player (and other players as well), compared to Blender. In Blender, it looks just fine. $\endgroup$ – Arthur K May 18 at 8:48
0
$\begingroup$

I also sometimes have videos smaller than full HD and when I open them in the player, the video player maximizes its window and makes the video display larger.

However, this is not a problem with Blender, but with the video player. Or maybe with the video format you choose. But if the file says it's 500 x 500 then it is all fine with the file. Maybe there is a setting in the player to play the video in original size.

What I meant by "it is not stretched to 1920 x 1080" is that the aspect ratio didn't change. It might be scaled to fit the height of 1080 and of course this might result in worse quality because not all software scales bitmap perfectly. But again: this is not a Blender problem. By the way, this is how it would look stretched to 1920 x 1080 and your object definitely isn't stretched like that:

stretched

$\endgroup$
4
  • $\begingroup$ I've just tried to rerender my animation, but at 1000 x 1000 Resolution. I exported without any loss. So there might be a problem with players themselves, as they are unable to play 500 x 500 correctly. Have tried to storm through the settings, did not find anything to tweak. I just found that 1000 x 1000 also looks good, which is why I am happy to stick around it in case I am unable to fix the issue. $\endgroup$ – Arthur K May 18 at 10:08
  • $\begingroup$ Although it's still not a Blender problem, here's one solution anyway: if you're using VLC player for example, in the menu bar there is Video > Always Fit Window. If you uncheck this, a 500 x 500 video will play in 500 x 500. You can also right-click on the video and choose from the context menu. Something similar is in good old Windows Media Player. I'm sorry I don't know all software video players, might be that yours doesn't have such setting since there was nothing to find... $\endgroup$ – Gordon Brinkmann May 18 at 10:40
  • $\begingroup$ I have downloaded VLC Player and made the adjustments you listed. It actually worked and started showing the animation as 500 x 500. But here is a question. If I upload this video to the web, it will still be stretched and quality-low. It looks like 500 x 500 is just not an ideal format that fits worldwide. Anyway, thank you for your help. Now I am a bit more aware of what was the problem :) $\endgroup$ – Arthur K May 18 at 10:59
  • $\begingroup$ You're welcome but as I said, that's not a Blender problem and maybe you should try to find a solution in a different forum. $\endgroup$ – Gordon Brinkmann May 18 at 11:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.