2
$\begingroup$

I am doing some very detailed weight painting on a texture. Using Blender 2.92.0. What I'd like to do is have a side by side in 3D view where on screen is in Weight Paint mode and the other is in Object mode but i can't find a way to do it.

When I select either mode, both screens go into that mode as shown here:

Weight Mode selected

When I select Object mode, it switches to this: enter image description here

This is what I want (NOTE: I photoshopped/cropped this side by side together to illustrate what I want, not a real image:))

enter image description here

I've been using Blender for a year so I'm fairly experienced but this one has me stumped (maybe because it is simple...). I'd be fine with mapping a key to either mode (eg F1=weight, F2=object) but in Blender 2.92 that doesn't seem possible (i've tried, again probably doing something stupid).

any ideas?

thanks

$\endgroup$
1
4
$\begingroup$

The simplest thing to do is just disable overlays on one of your viewports. Look on the right side (top or bottom, probably top) of your viewport for a button with a "show overlays" tooltip. Click it.

There may be some information you wish to see with overlays. In that case, click the drop-down arrow to the right of the overlays button and, while in weight paint mode, set weight paint opacity to 0. And, optionally, set fade inactive geometry to 0.0, or disable it. Selected vertices while in vertex mode will still be drawn; wireframes in face mode will be drawn.

$\endgroup$
2
  • $\begingroup$ ah, someone already answered it this is my solution too, I guess this is the right answer $\endgroup$ – Fernaldy Wiranata May 17 at 1:02
  • $\begingroup$ If you heard a slapping sound, that was my palm hitting my forehead... repeatedly. Ofcourse that is the simplest solution and it was staring me in the face the whole time. THANK YOU for your help Nathan, you just saved me a lot more frustration looking for a complicated answer. cheers $\endgroup$ – Kyle May 17 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.