3
$\begingroup$

I'm using blender 2.92 and trying to apply "merge by distance" on a mesh.enter image description here You can see in the gif that I first select the vertex to show it is overlapped, then "merge by distance". I expect that after the "merge by distance" was applied I would end up with only one vertex but we can see that nothing changes after I apply it.

For context, I created the mess by starting with a cube, scaling on the X axis then I scaled the two sides to 0 on the x axis to create an edge shape so at that point there are two edges overlapped. I'm guessing it has something to do with how I attempted to create the edge on this mesh?

$\endgroup$
0
7
$\begingroup$

You have not selected both vertices to be merged. One is 'In Front' of the other, so hiding it from selection.

You have 2 options:

  • AltZ, toggle into X-ray mode in the viewport, so the back vertex is no longer hidden when making the selection

or

  • Check 'Unselected' in the operator's F9 Adjust Last Operation panel, which will merge selected vertices to all others within the given distance, selected or not.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Right, it works that way. However why does it not if I select everything with A and then F3 > "Merge by distance"? Seems it does work if I view it in wireframe mode $\endgroup$ – Iustinian Olaru May 16 at 18:35
  • 2
    $\begingroup$ @IustinianOlaru If A followed by Merge by Distance isn't working, your threshold is probably too low. Also, the tool should work the same no matter what shading mode you're in. ;) $\endgroup$ – HISEROD May 16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.