1
$\begingroup$

I am probably missing something very obvious---maybe a modifier stack problem, more likely it's a parenting issue, or else I don't understand Mesh Deform well enough.

This is a simplified example. Wiggle bones are not appropriate for my problem. Let's pretend we MUST use Soft Body physics on a Mesh Deform cage.

I have a complex mesh with an armature. To give PARTS of it soft body physics, I have a Mesh Deform cage surrounding one part of the Mesh, so that poor old blender doesn't have to worry about squishing and pulling a trillion polygons. The Mesh Deform cage is parented to a bone in the Mesh's Armature so that it follows the Mesh appropriately. The Mesh Deform cage has Soft Body physics. I'm trying to cheese it so that only parts of the High Poly Mesh behave with soft body physics, without having to calculate that.

preview mode of a Mesh Deform Cage around a High Poly Mesh with an Armature

preview mode of a Mesh Deform Cage around a High Poly Mesh with an Armature

It seems fine, perfect even... until I render it. Rendering it breaks it.

Broken Render of a Mesh Deform Cage around a High Poly Mesh with an Armature

The Soft Body Physics is baked, and I have tried it without baking, too. It feels like a parenting issue, or something about vertexes and weight painting?

I have tried many things, and followed other threads with similar problems, but no one is asking this, specifically, that I could find. I apologize if this has been answered. If it has, I would like a simpler answer, explained like I'm five, because the complexity of rigging is very confusing for me.

If there is an amazing alternative for cheesing/faking soft body physics (capable of collision) on PARTS of a complex mesh which isn't wiggle bones, I am all ears.

I am so confused, sorry about this.

https://file.io/mw7LWq7f04QD this is a link to the blend file

$\endgroup$
2
  • $\begingroup$ Check for modifiers that are hidden in the viewport 🖥 but enabled in render 📷 $\endgroup$
    – TheLabCat
    May 14, 2021 at 21:50
  • $\begingroup$ I checked, they're all visible for rendering 📷, the problem persists :( $\endgroup$ May 15, 2021 at 0:07

1 Answer 1

1
$\begingroup$

The solution was to update Blender.

For future reference, the above set-up works. If anyone in the future is having trouble figuring out Mesh Deform with Armatures, I hope these pictures and descriptions help. Just make sure you've updated Blender.

And make sure you Bake any physics or wiggle bones before rendering.

$\endgroup$
1
  • 1
    $\begingroup$ Well, you’re not an idiot because the Lord doesn’t make idiots, and He made you. Easy mistake. God bless!😊 $\endgroup$
    – TheLabCat
    May 15, 2021 at 0:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .