1
$\begingroup$

This issue was solved by saving to EXR, however when loading that EXR into the VSE over a background a dark border appears around the transparent text that cuts through the glare and bloom. I'm using Blender 2.92.0. EEVEE with bloom Render layers -> Glare -> Composite (with "UseAlpha" checked) enter image description here

$\endgroup$
4
  • $\begingroup$ Following up to say I've just tried: EEVEE with no bloom. Render layers -> Glare (streaks) -> Glare (fog glow) -> Composite (with "UseAlpha" checked). The problem persists $\endgroup$ May 13, 2021 at 21:06
  • $\begingroup$ This seems like a bug to me. Here’s another question discussing the same thing: blender.stackexchange.com/q/203616 It seems like maybe the VSE doesn’t handle Alpha Over compositing correctly for images with premultiplied alpha. If you can add the background in the compositor rather than in the VSE, that should work better, but otherwise I don’t have any great ideas. $\endgroup$ May 13, 2021 at 21:52
  • $\begingroup$ Thanks @AlexisKing, these workarounds might work $\endgroup$ May 13, 2021 at 22:01
  • $\begingroup$ Actually, I take it back—I realized the VSE operates in sRGB by default, which is the root cause of your problems. See my answer. $\endgroup$ May 13, 2021 at 22:17

1 Answer 1

1
$\begingroup$

By default, the Video Sequence Editor operates in the sRGB color space, while the Compositor always operates in the Linear color space. (You can read more about the difference in the Color Management section of the Blender documentation.)

When you render to OpenEXR, the information in the image is stored in the raw Linear color space. This means that the colors have not yet been mapped to sRGB, and in fact there are many possible different ways that mapping could be done (as changing the View Transform and Look settings can illustrate). Although the VSE does handle images in the Linear color space even when compositing in sRGB, the compositing operations themselves still happen in sRGB, which means the image must be converted to sRGB before the alpha blending is applied.

This is fraught with potential problems, and although I sadly can’t say with confidence why exactly this leads to black fringing in your example, it seems wiser to play it safe and do this compositing entirely in the Linear space. You can set the VSE to Linear in the SceneColor Management panel:

This eliminates the fringing in the rendered result.


There are other tradeoffs related to the choice of VSE color space, and the full subject is too complex to attempt to cover here. But if all you are doing is compositing rendered output from Blender itself, using the Linear color space is almost certainly a perfectly fine choice.

If you find that using the Linear color space does cause problems for whatever reason, one solution could be to use multiple scenes, one of which uses the Linear color space in the VSE, the other which uses sRGB. Then you can do your video compositing in two passes, first compositing in the Linear space and outputting sRGB video, then further processing the sRGB video in the sRGB space. Of course, if doing everything in the Linear color space works fine for you, that is preferable, since that is much simpler.

$\endgroup$
1
  • $\begingroup$ Whoa this is great! I would like to note that simply making this change with the image in the project didn't work. I had to reimport the images after making this change. I suppose something happens on import for the item. $\endgroup$ May 13, 2021 at 22:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .