1
$\begingroup$

I am making an ocean and playing around the setting to create a foam and waves that a boat would make. I am learning from youtube and found this https://www.youtube.com/watch?v=smArCTzxGpE. I tried to apply the same settings on my ocean (OceanAMovementForStack.blend).

  1. When rendering animation from the example from youtube, waves displacement worked on every frame, but the foam sometimes randomly disappeared. I fixed that by using Bake all dynamics in Physics properties. And that example now works perfectly.

  2. In my project when rendering animation, foam is always present, but waves only work on the frame that is being rendered (so wave trail is gone from previous frames). I tried fixing that as before, by baking. Weird things happened. First I only baked Paint (foam), and waves worked perfectly, but the foam was totally gone. When I baked only waves or baked both, the waves would be completely gone.

  3. I also tried moving dynamic paint above subdivison in Modifier properties but it just broke the render animation even more.

I don't know what to do. Can someone please help me achieve the same results as in youtube video? I would be thankful so much! I am posting my own project and the project from youtube. Also posting hdri used as you'll probably have to set it in world settings if you don't want everything to be purple.

1st time asking a qustion and don't know how to post a .blend file, so here's a link to google drive: https://drive.google.com/drive/folders/1N_p0dyywBFKimTRtbjtcAiI9tQQLXMiy?usp=sharing

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.