0
$\begingroup$

I've just been looking at various similar questions and can't seem to find the solution so thought I'd try asking here juts in case someone has had a similar issue.

I've been working with this project for a while now and suddenly the HDRI stopped showing as a background in rendered view. I've been using cycles but changed it to Eevee and still doesn't show. I've checked everything in the world settings and the viewport shade settings and still isn't showing. The lighting seems to be fine, it's just the lack of image.

Apologies in advance if this is a really easy obvious thing! I'm very new to Blender and would appreciate some help from someone a little more experienced than me.

screenshot of workspace

Thanks! Anna

$\endgroup$
2
  • 1
    $\begingroup$ Under Render properties > Film, do you have 'Transparency' checked? If so, uncheck it and try rendering again. $\endgroup$
    – John Eason
    May 12, 2021 at 11:33
  • $\begingroup$ It's now working, thank you for your help! $\endgroup$
    – Anna
    May 17, 2021 at 11:55

1 Answer 1

1
$\begingroup$

In your screenshot, your view is set to Ortographic not Perspective, this usually makes the HDRI just a blurred color instead of a real image. You can toggle between those views with Numpad 5. However, then there is still color, but your viewport shows this grey checker texture which means you've set the background to Transparent. Go to Render Properties > Film > Transparent and disable it.

enter image description here

$\endgroup$
2
  • $\begingroup$ That's really helpful thank you! It's now working. Apologies for the late reply I haven't been working on this project for the week because of uni deadlines. $\endgroup$
    – Anna
    May 17, 2021 at 11:54
  • $\begingroup$ You're welcome! You might consider to mark the answer as "Accepted" to indicate others with similar problems that a solution is found. Read more about it here: What should I do when someone answers my question? $\endgroup$ May 17, 2021 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.