0
$\begingroup$

I have two objects that I want to fully merge into one object. I have gone through the steps of about 10 posts online and all of them leave the former shared edges visible (when I can get them to work at all). In all cases, the former shared edges are still visible. The program still thinks they are two joined objects instead of one, as can be seen if I delete one of the vertices.

How do I get rid of these visible intermediate vertices/edges?

Two objects (before) Results of joining faces (with dividing line)

Thanks in advance (since I can't write comments).

$\endgroup$
4
  • $\begingroup$ I'm using the latest Blender and Windows 10. $\endgroup$
    – GregJ7
    May 11 '21 at 18:17
  • $\begingroup$ So you joined both objects using Ctrl+j? Blender won't know what vertices to merge automatically, so you'll have to edit or use a clean-up function like 'Merge by Distance' or 'Decimate geometry'. Is that what you want? $\endgroup$
    – Joachim
    May 11 '21 at 18:20
  • $\begingroup$ I tried joining them with several methods, but not control-j, which does nothing for me. I tried both merge by distance and decimate geometry after I had joined them with a union modifier. A copy of the objects can be found at u.pcloud.link/publink/… Note that the lower vertices are extruded to the upper ones in that file. I can remove that if someone wants a cleaner version. $\endgroup$
    – GregJ7
    May 11 '21 at 20:08
  • $\begingroup$ In Edge mode, select the edges you want to delete and then press X > Dissolve Edges. $\endgroup$
    – John Eason
    May 11 '21 at 21:25
0
$\begingroup$
  • Delete the edges between both objects;
  • Click one of the vertices of one of the ends of the objects that you want to connect, and use Shift+sCursor to selected, so we can use the 3D cursor's location to move the other object to the exact position of its counterpart.
  • Since for me the 3D cursor snapped to one of the wrong vertices, I quickly separated the object using p, then g and z to grab it along its Z-axis, and it snapped right in place.
  • Select both objects, use Ctrl+j to join.
  • Remove the faces that are currently between the vertices you want to get rid of.
  • Select the vertices surrounding the deleted faces, and navigate to Mesh → Clean Up → Merge by distance, and tweak the value to delete the 14 double vertices (by turning it all the way down).
  • Now select the vertices that are left, click Del, and select the Edge Loops option.

Both models are now joined and clean:

enter image description here
(Note: I rotated the model so it fits this page better in most cases.)

$\endgroup$
5
  • $\begingroup$ If any of these steps is unclear, please let me know, and I'll edit my answer. Good luck! $\endgroup$
    – Joachim
    May 11 '21 at 21:26
  • $\begingroup$ Thanks for the long explanation. I am so newb I couldn't execute the steps properly—so then I tried using the difference modifier to chop both the intermediate ends off in an effort to reset the state of the vertices/edges/faces to something simple. Then I extruded one of the faces in both directions (experimenting) and lastly snapped the two faces together. (I can't move either object, but need to keep the same total length.) Then X->Edge Loops worked for some of the junctions, but not the last. Could you look at u.pcloud.link/publink/… ? $\endgroup$
    – GregJ7
    May 11 '21 at 22:50
  • $\begingroup$ Once that new file is opened, go to Edit Mode, and Wireframe mode (by pressing 'z'). Click 'Face Select' next to the Object Interaction drop-down menu (upper left corner, under File | Edit | Render), and you'll notice there is still a face between the vertices (step 5 in my answer). Press 'Del' → 'Faces'. Go to Vertex Select Mode, select the vertices you want to remove, press 'Del', and select 'Edge Loops'. That should do the trick. $\endgroup$
    – Joachim
    May 12 '21 at 9:49
  • $\begingroup$ That worked, thank you! So just deleting selected vertices with X -> Edge Loop doesn't work if they are still being used to define a face? $\endgroup$
    – GregJ7
    May 12 '21 at 11:40
  • $\begingroup$ Exactly, because they're not merely a loop at that point :) Glad it worked! Can you accept the answer to mark the matter as solved? $\endgroup$
    – Joachim
    May 12 '21 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.