0
$\begingroup$

I am dealing with a certain model. In DAZ3D, the bone rotation is very convinient and what I would consider "natural". When I export the model and import it in Blender and try to rotate the finger bones as I do in DAZ3D, it doesn't feel natural. The bones do not rotate along the axis.

Here is a video of what I'm experiencing.

How could I achieve the same bone rotation strategy in Blender?

Thank you!

enter image description here

Here is my blend file:

Edit: I have set the orientation to local as somebody suggested, but it wouldn't help. Here is a video:

Edit 2: Somebody suspected improper import settings. I have tried many ways, but I couldn't get it to behave normally. If anybody would give it a try, here is my model.

Edit 3: I think it's a bug. If I import the same fbx into DAZ3D again, it works perfectly fine.

I have therefore filed a Blender bug report here.

enter image description here

$\endgroup$
1
$\begingroup$

Do the following in any order, it doesn't matter.

Select Rotate tool from toolbar.

enter image description here

Enter pose mode.

enter image description here

Set your Transformation orientation to local. Set your selection pivots to be individual origins as rotating a group of bones doesn't usually make much sense with bones. Now you can rotate one or more bones and those will each rotate from their own pivot. You can curl fingers for example.

enter image description here

If you don't like gizmos for some reason, you could also select some bones, then press R then X after it, and then move your mouse to rotate your bones along x-axis. This of course works for Y an Z-axis too.

$\endgroup$
3
  • $\begingroup$ This looks like what I need, but it doesn't work in my case. I have updated my post with some additional info. $\endgroup$ – tmighty May 11 at 18:53
  • 1
    $\begingroup$ Well it seems like you bones are not aligned along the length of fingers, most likely due to some non-optimal import settings. $\endgroup$ – ezez May 11 at 19:25
  • $\begingroup$ I have filed a bug report. Because when I import the same fbx in DAZ3D, the bone roll is perfectly fine. Just not in Blender. No matter which import settings I choose. $\endgroup$ – tmighty May 13 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.