0
$\begingroup$

I'm exporting using the AutoRigPro exporter. In Blender, the weights look fine (the first image). However, After auto-weighting to my rig, I needed to do some manual painting around the wrists to fix deform issues. Then on export to FBX I get the issue you see in the second image.

enter image description here

Any vertex I painted manually or modified in the slightest with the blur tool doesn't seem to export properly.

I checked and the bone I'm weighting to is the correct one, and is exported. The weights are normalized. There are no more than 4 weights per vertex. Any idea what's going on here and how to fix it?

Removed the link to the source file because I solved the issue. enter image description here

$\endgroup$
4
  • $\begingroup$ I'm not seeing weighting issues when exporting and then importing into Blender, and then just doing a tiny test. Have you tested a Blender import? The very first thing I'd do is get rid of the empty armature modifier (you have two on your meshes), which is likely to cause problems. Your post-armature data transfer on your face is not going to export properly, and you should consider applying that before export if appropriate. Also consider running a normalize all operation on vertex groups prior to export-- may affect export, but in a way that wouldn't show in Blender. $\endgroup$ – Nathan May 11 at 15:54
  • $\begingroup$ Thanks @Nathan it may be because I was using the AutoRigPro exporter rather than the default exporter. This is necessary for me because of naming conventions for UE4. Good catch on the empty armature modifiers, I didn't notice those. AutoRigPro is supposed to have those targeted to the "rig_add" armature. I went ahead and got those targeted properly and still no dice. I had also run the normalize all operation before posting this question, and that was no luck; but great thought. I also made sure to limit to 4 weights per vertex. $\endgroup$ – Tyler May 11 at 16:59
  • $\begingroup$ Ahh and the data transfer is just for custom normals. After modifying normals their smoothing breaks on morphing or skeletal deform. But using a data transfer modifier fixes that in blender. Not a problem on export for me, but if I were transferring some other data I definitely can see where that would be an issue to have it applied after the armature modifier. Great insight $\endgroup$ – Tyler May 11 at 17:01
  • $\begingroup$ Yeah, the export function matters, as well as where the actual animation is being displayed ("Autodesk FBX Review") and unfortunately, I have access to neither to test. If problems can be recreated in import-to-Blender, and/or via out-of-the-box FBX export, you may get more eyes. Sorry, I missed that you mentioned that weights were already normalized. $\endgroup$ – Nathan May 11 at 17:15
0
$\begingroup$

This was due to conflicting vertex groups in the ARP exporter. To fix it, I removed vertex groups that didn't match the secondary controller mode for ARP (which were added in a different bind session set to "none"). In my case, I needed to remove the following groups because my current bind is set to "twist:"

-arm_stretch

-forearm_stretch

-arm_twist

-forearm_twist

-thigh_stretch

-thigh_twist

-leg_stretch

-leg_twist

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.