1
$\begingroup$

I have recently been learning the compositor feature and have been running into some confusing issues. When i connected the glare feature to add glow to a scene, absolutely nothing happened...

also i recently made another scene where i have multiple glowing objects and all but one is glowing?!?!?! see attached image.

I've used glare multiple times now with no problems but twice now i ran into this problem.

thank you in advanced!

scene with missing glowNode Setup

Updated Glow

@GordonBrinkmann

@Daniel - https://drive.google.com/file/d/1UlLXuRFI9rgjxSwlm8Kr1q2K2dvb0YtG/view?usp=sharing

$\endgroup$
3
  • 1
    $\begingroup$ Hi. If you haven't already figured out the answer, please add the .blend file $\endgroup$
    – Daniel
    May 11, 2021 at 3:40
  • $\begingroup$ Have you tried reducing the Threshold value in the Glare node? 5.3 seems quite high for those not really strong emissions... And I think there are two glowing, the green and the yellow one ;) $\endgroup$ May 11, 2021 at 6:45
  • $\begingroup$ updated photo with adjusted threshold and .blend file with assets added. thank you guys! $\endgroup$
    – Mpizzz89
    May 11, 2021 at 14:45

1 Answer 1

1
$\begingroup$

I don't know about all of your scenes. But in the screenshot the emission of your glowing objects doesn't seem very strong, but the Threshold in your Glare node is set to 5.3 which is quite high.

Here's an example: the following cubes have three different colored emission shaders, each with a different strength. The red has a strength of 2, the blue one a strength of 4 and yellow only 1.

glow colors

They look not to different in brightness although they are, which of course depends partially on their color. If you now plug the image into a RGB to BW node which sets R = G = B according to the brightness, it looks like this:

bw values

Although the yellow emission has a strength lower than blue and red, it has the highest value. And especially important: although they all have an emission strength of 1 or higher, all values are below 0.8 which is relevant for the Threshold of the Glare node.

Since no value of any emission was 0.8 or greater, setting the Threshold to 0.8 allows no glow on any of the three cubes.

threshold 0.8

But if you lower it to 0.7, a value that blue and yellow exceed, the glow starts to show on those cubes. The red one is still to dim.

threshold 0.7

Actually I don't know why the blue glow looks more intense than the yellow one, maybe because once the threshold is passed, the higher strength plays a role as well. But apart from that it's important that your threshold is low enough to let the emission through. An emission strength of 5 doesn't necessarily mean it's really brighter than 4 (unless it's pure white I guess).

Here's just one tip how I usually add glow to my images. In the Glare node I set the Mix value to 1, this way it only outputs the glow effect. Then I add it to the image by plugging it in the second socket of a Color Mix node. This way I can use the factor to reduce the glow if it's too intense, but also boost it by setting the factor higher than 1.

glow mix

EDIT: Now I've downloaded your file and worked a little on it. First of all here are some things about your Compositor setup: the Mix factor in your Glare node is still on 0.3, which means you don't have the glow separately on the output but mostly the original image with glow on top. You should set it to 1 so that you have full control if and how much glow you want to add in the Mix RGB node. There you just have a factor of 0.575, which means you're adding a lot of the original image on top of itself but not the full glow. Another thing is, you're plugging the denoised image into the Glare node. But denoising averages values which could also lead to reduced brightness and thus less glow. And by the way: the Denoise node works quite well and it doesn't need enabled Sampling > Denoising in the Render Tab. That just makes the rendering slower and the Denoise node in the Compositor works better. Actually I don't even enable Denoising Data when I use it, in normal scenes it doesn't make a noticeable difference. With Denoising enabled my render time was 47.81 seconds, without 35.10 seconds.

my compositor

Here's my Compositor setup:

original composite

Note that I've set Mix in the Glare node to 1 and also the Add factor in the Mix RGB node is set to 1. And the quality of the Glare is set to Medium instead of High - usually this is good enough and it results in more glow. With these settings I got a good glow on all objects with green and yellow at a strength of 10, red at 15 and blue with a strength of 30. The problem is, red and blue are always "darker" than green and yellow so they need higher values. Also the more saturated the values are the less bright they get, for example if you have R/G/B = (0/0/1), even multiplying by 100 will never make R and G more than 0. But with (0.01/0.01/1), R and G get higher, too which will result in emission that's turning to white the brighter it gets. I also moved the black slider on the blue emission material slightly to the left so there are less dark parts in the material.

Now for comparison, your blend file:

original image

My version, of course it looks darker because I've decreased the strength of each Emission shader. But since the emissions of the rings are the only light sources, the surroundings become darker, too:

my version

To compensate for that, I've made an "enhanced" version. First of all I added the picture onto itself as your setup does eventually, so it brightens up the environment. Then I've added the glow with a factor of 2 instead of 1. Now it looks like this:

my enhanced version

All in all, the crucial things are these:

  1. Blue emission and also red will always be darker than green or yellow, so the effect could be less or needs more emission strength.
  2. You should always set the output of the Glare node to 1, to show only the effect and not the original image mixed in. This way you can decide how much effect you add to the picture, especially going higher than "full effect" cannot be done with the Mix factor in the Glare node.
  3. It's best to use the direct image output for the Glare node instead of an already denoised version, although it might not make a difference in most cases.

Here's my edited blend file, with enhanced and standard composition. I didn't pack the textures into it because that would've been too big:

$\endgroup$
16
  • $\begingroup$ thank you, lowering the threshold helped a lot. the only thing is with the emission values, originally i set them to 20 but for some reason the blue has to be set to 100 and still the glare effect isn't equal. And the add feature is something i will be using from now on. $\endgroup$
    – Mpizzz89
    May 11, 2021 at 14:22
  • $\begingroup$ I can't see it in the screenshot, is the glowing part directly visible for the camera or is it behind glass? It reduces the emission strength a lot if it has to shine through glass. $\endgroup$ May 11, 2021 at 14:52
  • $\begingroup$ I wasn't home until now and couldn't check the blend file. I will rework it a little. $\endgroup$ May 11, 2021 at 17:35
  • $\begingroup$ @Mpizzz89 I've edited my answer to show you what I would change. $\endgroup$ May 11, 2021 at 20:46
  • $\begingroup$ This is beyond amazing, thank you so much! my node knowledge mostly comes from youtube so not always reliable. $\endgroup$
    – Mpizzz89
    May 11, 2021 at 23:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .