I'm pretty new to Blender, so forgive me: I'm currently following this tutorial but for a different mesh, not text. https://www.youtube.com/watch?v=jcPV3AkMRLI&t=134s

The problem I'm facing is after baking, the fluid is only created at a certain part of the mesh:

enter image description here

The blue section are the liquid particles. Also, I subdivided the mesh a lot because I heard that would help make the fluid simulation look smoother, but I have a version that isn't subdivided if that's important.


I want to create an effect like the entire mesh is melting into the ground, but for some reason Blender only wants to create a liquid simulation for the head area.


1 Answer 1


First, I noticed that your domain is very large. Only make it as big as it needs to be. Extra space means unused voxels using CPU time and slowing down your simulation calculation.

Second, there was a misunderstanding about the subdivision. You want multiple voxel subdivisions on the domain. Yours is set to 180. More subdivisions of the simulation via this setting means more, smaller voxels, which means your fluid will look less like Minecraft (gigantic 1m voxels there). The current setting is likely plenty for a domain around this character, but maybe not if it’s so huge. If the voxels are bigger than the thing emitting fluid it may not work as expected. PS: Don’t subdivide the domain mesh directly in edit mode as it won’t influence the simulation but only increase your poly count.

Thirdly, make sure the model is manifold, and that the normals are calculated correctly. That is, no open faces, no duplicate vertices (try Select All, Merge -> By distance), and no intersecting mesh. Once you’re sure of that, Select All, and go to Mesh -> Normals -> Recalculate outside. Normals mark which direction of a face is outward, and I believe fluid sim pays attention to them.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .