2
$\begingroup$

Dear Blender Community,

right now I am trying to make a transparent glass shape with objects inside. I tried to smooth the shape via subdivison and smooth modifiers.

With the subdivision the glass has a nice clear look but i get a lot of hard edges enter image description here

Without it appears smoother but unfortunately it is appears less clear

enter image description here

Do you have an idea how I can get a smooth an clean look for the shape. Thank you :)

topology without subdivision topology without subdivision

topology of the model with applied subdivision results in having bulky edges

topology of the model with applied subdivision results in having bulky edges

$\endgroup$
5
  • $\begingroup$ Did you smooth shade it after using the subdivision surface modifier? - (in object mode with the object selected) right-click > Shade Smooth (not the same as the "smooth" modifier). $\endgroup$ May 10, 2021 at 15:21
  • $\begingroup$ yes I did. A collegue told me the edges after the subdivision are a result of my mesh being to complex. $\endgroup$
    – Macks
    May 10, 2021 at 15:24
  • $\begingroup$ Yeah, it's hard to tell without seeing your underlying topology (mesh in edit mode), but edges that are close together will form "creases" and any kind of bevel will mitigate the "roundness" of edges. It might be helpful if you could post a pic of your topology as well, to better understand what's really going on. If you're really stuck you might also consider posting your .blend file (or a minified example). You can do it here if you wish - blend-exchange.com $\endgroup$ May 10, 2021 at 15:26
  • $\begingroup$ Hey Christopher, thanks for your reply. I Will add a photo of the topology to my post. $\endgroup$
    – Macks
    May 10, 2021 at 15:59
  • $\begingroup$ adding the actual blend file would be more helpful to me. $\endgroup$ May 10, 2021 at 16:57

1 Answer 1

2
$\begingroup$

A couple of changes to default settings

The Principled BSDF shader has a default Base Color around .8, which means glass will be a little dark by default. You can raise the base color to 1.0 for perfectly clear glass.

These dark spots -

enter image description here

are caused when the light reflects internally a number of times that exceeds the number of bounces allowed in render settings.

enter image description here

Usually it's the number of Glossy bounces which you can change here:

enter image description here

You can learn more listening to this talk.

To the model

When modeling for subdivision it is often to your advantage to leave your mesh as low poly as possible, and let the interpolation algorithm do the work of placing the additional vertices with mathematical precision. Shade Smooth will do the rest by interpolating the normals between the generated faces.

Observe the following model, and see how it is represented in edit mode.

enter image description here

(5 levels subdivision)

enter image description here

The glass tubes might be easier to construct using a curve. This takes a lot of the work out of positioning. I added a solidify modifier to this curve.

enter image description here

As a bonus, the curve may serve as a constraint for animation.

$\endgroup$
1
  • $\begingroup$ Thank you Allen for your help. So my model has to much geometry I guess. Is there any way to fix the model getting rid of the edges? Or do I have to rebuild everything? $\endgroup$
    – Macks
    May 10, 2021 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .