2
$\begingroup$

While fiddling around getting the letter F filled up by a fluid for an animation, I don't get the fluid to reach the horizontal parts of the F.

So far I´ve tried:

  • Domain resolutions: 32-128
  • Effector thickness: 0.2 (it leaks!) to 1.5 (its so thick the fluid runs over the entire letter)
  • Varying the size of the flow source

Tried it now it just leaves me with no visible fluid after baking at all. Pretty much the same way as if I´m adding a new fluid simulation to any existing work. Don´t know if this is a bug or what not because whenever I apply a fluid simulation during a work it doesn't show any fluid. But when I do the same in a new project (so that the fluid simulation is alone) it works.

Switching from All to Replay on the cache displays the fluid but it doesn't behave the right way.

enter image description here

Q: How to fill up every part of the letter with a fluid?

$\endgroup$
3
  • $\begingroup$ please use this blend-exchange.com to upload your file. thank you. $\endgroup$ – Chris May 9 at 17:51
  • $\begingroup$ Did you follow my instructions? Did you add solidify modifier? Did you move it to the top? $\endgroup$ – Chris May 9 at 20:02
  • $\begingroup$ Start from your uploaded file. Not from any file you changed in the mean time. $\endgroup$ – Chris May 9 at 20:03
1
$\begingroup$
  1. Select your 'F'

  2. add solidify modifier

enter image description here

  1. move solidify modifier before fluid

  2. bake fluid again (by the way, i use 80 as resolution (much quicker to bake))

and you get:

enter image description here

$\endgroup$
3
  • $\begingroup$ Tried it now... it just leaves me with no visible fluid at all after baking..!? Pretty much the same way as if I´m adding a new fluid simulation in an existing work. Don´t know if this is a bug or what not... because whenever I apply a fluid simulation during a work it doesn´t show any fluid at all. But when I do the same in a new project (so that the fluid simulation is alone) it works. $\endgroup$ – Hardashell May 9 at 18:23
  • $\begingroup$ Change to modular and check is resumable in domain. Then you can bake again. $\endgroup$ – Chris May 9 at 18:49
  • $\begingroup$ Hi. Nope... still no visible fluid after doing that. Weird.... $\endgroup$ – Hardashell May 10 at 6:40
1
$\begingroup$

After playing around with this, I think the problem is with the Effector settings. The collider is a very thin shell but with a Surface Thickness set to 0.5. I believe this results in the collider being unable to determine the 'inside' and 'outside' of the mesh when allocating obstacles in the domain.

Simply changing the Effector settings to set Surface Thickness to 0.0 and enabling 'Is Planar' seems to fix the problem :

effector settings

The 'Is Planar' option tells the simulation to treat the mesh as a set of faces instead of a manifold volume.

result

$\endgroup$
1
  • 1
    $\begingroup$ Wow. That did it! Big thanks. Imagine... ticking the planar-box was it. $\endgroup$ – Hardashell May 13 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.