I used the Boolean tools to subtract one mesh to another and thus create this mesh.

enter image description here

The result is not very clean. How can I do to best clean this result and get a nice smooth surface?

Do I need to re-arrange the vertex one by one, or is there a faster, simpler and more effective solution?

  • $\begingroup$ can you share the blend file. There is a faster way, but it would be easier to explain on the actual blend file, one step at a time. $\endgroup$ May 8, 2021 at 23:48
  • 1
    $\begingroup$ By the way, you can make of the problem disappear by turning on auto smooth in properties editor -> object data properties -> normals $\endgroup$ May 9, 2021 at 0:34
  • $\begingroup$ @MartyFouts No sorry, i can't share the blend file! $\endgroup$
    – GilbertOOl
    May 9, 2021 at 1:19
  • $\begingroup$ @MartyFouts you can propose a solution, it's fixed with your solution ! $\endgroup$
    – GilbertOOl
    May 9, 2021 at 1:21

1 Answer 1


The easiest way to fix this problem is to select the object, and go to properties editor -> object data properties -> normals and enable auto-smooth with an angle of 30 degrees or more:

auto smooth enabled..


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .