0
$\begingroup$

I'm facing issues when I tried to draw with reference images aside to help with complex topology. I add them in Quad View area, they are fine and appear in local view, but the moment I disable perspective mode, they started to act strange. I don't know what's going on, please help.

(With Display Perspective enabled)

enter image description here

enter image description here

enter image description here

(Without Display Perspective enabled)

enter image description here

enter image description here

Everything was supposed to be well after re-enabling Display Perspective.

$\endgroup$
7
  • $\begingroup$ can you provide blend file? $\endgroup$
    – Chris
    May 8 at 18:51
  • $\begingroup$ You'd need to pack the images into the blend file for us to be able to see them, however it sounds as if they're working exactly as they should be. - If you have Show In perspective view unchecked and Show In orthographic checked, you'll only see the image 'head on'. As soon as you rotate the view the image will disappear by design. $\endgroup$
    – John Eason
    May 8 at 23:14
  • $\begingroup$ How can I pack 'em to blend file? Blender keeps referencing their paths and doesn't bundle... $\endgroup$
    – AtomX
    May 9 at 7:37
  • $\begingroup$ File > External Data > Pack all into .Blend. That's in Blender 2.92 but it's the same in 2.83. $\endgroup$
    – John Eason
    May 9 at 8:04
  • $\begingroup$ So... no one found out what's going on...? Should I report it as bug? $\endgroup$
    – AtomX
    May 9 at 13:15
1
$\begingroup$

When Display Perspective is disabled in the settings of the Empty then it always disappears as soon as you change your view from orthographic into perspective view. Enable it to see the Empty in perspective view as well.

When enabled and the frame is there but appears empty, that's because the face normal (or the orientation axis of the Empty, since there is no real "face") is pointing the other way. Above the Display Orthographic setting, switch Side to "Back" or "Both". At the moment it's set to "Front" but your view is on the back of the Empty. Or you simply rotate it 180° on the Z axis if you want to keep one side transparent.

Another reason if it still doesn't appear is that Only Axis Aligned is checked. This makes the image disappear if the view is rotated off-axis.

Best is you check out all the settings in the red framed area in this image. The settings shown there are the default values.

empty image

$\endgroup$
7
  • $\begingroup$ I enabled display perspective later, but only the offsets coordinates are visible... I updated my question to reflect the current situation. $\endgroup$
    – AtomX
    May 9 at 16:53
  • $\begingroup$ When Display Perspective is disabled, well everything is empty... Only the cube geometry remains visible. $\endgroup$
    – AtomX
    May 9 at 17:09
  • $\begingroup$ I've edited my answer to explain why this is happening. $\endgroup$ May 9 at 17:34
  • $\begingroup$ Are we talking about 2.92? I don't know, even changed Depth to Default and tried others Sides (Both too)... Rotated all possible angles... It's very difficult to work like this. $\endgroup$
    – AtomX
    May 9 at 18:52
  • $\begingroup$ Oh, I'm sorry, I forgot to tell you you have to disable Only Axis Aligned as well. In Blender 2.90 it didn't make a difference (not on one of my computers at least, I checked it to make sure this wouldn't cause a problem), but with 2.92 and 2.93.0 Beta this option is working. Actually I wondered in 2.90 why it didn't have an effect because "only axis aligned" sounds to me like it's normal that you can't see it when you rotate the view off-axis. I'll add it to my answer. $\endgroup$ May 9 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.