0
$\begingroup$

I'm using Blender 2.92 and I've made an animation in around 110 frames using the Auto Key option. But suddenly Blender stopped adding keyframes upon rotating the controllers. It allows me to animate the movement only. I can't even animate the scale for the controllers that have the scale functionality either. I am using the Vincent model rigged in Blenrig. I checked the channels, they're not locked, restarted my computer, but no joy.

Moreover, I can animate the rotation by using the Rotation channels in the N panel.

File attached for your kind support.

https://www.mediafire.com/file/gxf397m7lq4eh02/Vincent_Animation.zip/file

$\endgroup$
2
  • $\begingroup$ please....if you upload a blend file, keep the file suffix as .blend. This makes our life easier. And next time please use blend-exchange.com to upload your file, because this is one of the "official" sites to share blend files. Thank you. $\endgroup$ – Chris May 5 at 13:25
  • $\begingroup$ Oh I didn't know. Duly noted! $\endgroup$ – Abedd May 5 at 21:57
0
$\begingroup$

your end frame is at 113 so Blender will not autokey your animation over this end frame. If you raise this to ...e.g. 1000 you can auto - keyframe a bit more time.

enter image description here

$\endgroup$
1
  • $\begingroup$ I raised the end frame higher but it didn't fix it. You see, I am still able to animate on the translate axes, but not the rotation and scale. Like Blender locked the rotation and scale for some reason. And I started to believe that it's really not an animation thing. I just disabled auto key and tried to rotate and scale the still tree in the scene, it won't let me do it. Is there something in Blender that locks the rotation and scale beyond the N panel? $\endgroup$ – Abedd May 5 at 21:45
0
$\begingroup$

Found it!

In the N panel > Active Tool and Workspace settings tab > Options header > Transform > Affect Only

so I accidently checked "Locations", and they're suggesting to uncheck all (Origins; Locations; Parents).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.