0
$\begingroup$

I have imported a .stl model into Blender with the goal of isolating and shading various parts of the model (painting it). I'm stuck with this format as a starting point.

In the Modeling pane I've selected the first part of the model that I want to isolate and I believe I want to create a Surface so that it can then be shaded.

Assuming that creating a Surface is correct, I can't figure out how to. Right-clicking the selected vertices brings up the Vertex Context menu but I see nothing about Surfaces.

Is there a step I'm missing or a menu?

Here are some images to demonstrate what I'm seeing.

This is what it looks like when I select using the circle and box tools. enter image description here

After some playing I realized I didn't have everything and after selecting 'more', I get this

enter image description here

Now it looks like I have the whole blade selected (although I'm really not sure).

So time to make some faces, and when I hit F, this is what happens. enter image description here

I would expect to see something new in my Scene Collection, nope. When I pop over to the Shading pane, nothing new to see, in fact, the disappearance of the geometry is the only indication that something (who knows what) happened.

$\endgroup$
6
  • $\begingroup$ Blender calls surfaces 'face's so you're looking to create faces. Are you sure there are no faces in the model? To create a face, select a group of vertices and type the f key. That will fill the vertices with a face. Unfortunately if your model has no faces at all you'll have to do that for every face. Can you share your blend file? $\endgroup$ Commented May 4, 2021 at 15:24
  • $\begingroup$ Thanks for your response. I'm reasonably sure there are no faces, this is a unmodified .stl file. In Daz it was a single "surface", I'm not sure if that means it's a single face in Blender. In any case, when I try to create a face from the selection, I get an error, "Could not create merged face". $\endgroup$ Commented May 4, 2021 at 15:57
  • $\begingroup$ If the model has no faces, you will see nothing but black dots and lines. $\endgroup$
    – TheLabCat
    Commented May 4, 2021 at 18:23
  • 2
    $\begingroup$ Check out docs.blender.org -> Modeling $\endgroup$
    – TheLabCat
    Commented May 4, 2021 at 18:23
  • $\begingroup$ Yes, exactly, the model in question, when I bring it in, has only lines and dots, I'm not sure how that helps, can you clarify (without referring me to the documentation). $\endgroup$ Commented May 4, 2021 at 19:31

2 Answers 2

1
$\begingroup$

what @ZargulTheWizard is trying politely saying to you is that your Blender knowledge could be a little bit more advanced. You are assuming too much with too less knowledge.

"A common object type used in a 3D scene is a mesh." (from Blender docs). A mesh consists of vertices (points), edges (connections between points) and faces.

"face A closed set of edges, in which a triangle face has three edges, and a quad face has four edges. A polygon is a coplanar set of faces. In systems that support multi-sided faces, polygons and faces are equivalent. However, most rendering hardware supports only 3- or 4-sided faces, so polygons are represented as multiple faces. Mathematically a polygonal mesh may be considered an unstructured grid, or undirected graph, with additional properties of geometry, shape and topology." (from wikipedia)

With "F"

  • you can create an edge between two selected vertices
  • you can create a single(!) face between more than two selected vertices

Answer to your assumption: "I would expect to see something new in my Scene Collection, nope. When I pop over to the Shading pane, nothing new to see, in fact, the disappearance of the geometry is the only indication that something (who knows what) happened.":

But if you created edges or faces, you just change the mesh of an object, you do not create new objects at all which you could see in the outliner (scene collection).

If you just see points as in your last posted picture you just have vertices. Nobody ever would then press "F" to create one single face because that are way too many vertices and it would look like shit.

Next to your sentence:

"In the Modeling pane I've selected the first part of the model that I want to isolate and I believe I want to create a Surface so that it can then be shaded."

-> in the picture you posted to that you already have a surface (which is called faces in Blender -> try to use the right terms, else there will be lots of misunderstandings). You can "see" the faces by the gray color. The dots are the vertices and the "lines" are the edges.

Hopefully this helps you a bit. Maybe you should watch some beginner tutorials like here...

they are free: https://www.blender.org/support/tutorials/

$\endgroup$
-4
$\begingroup$

Thank you for those who responded but I found the answer on my own.

To solve the problem, the first thing I had to do after importing the mesh is to put a material on the whole model. This, evidently (implicitly?) automatically puts faces on all of the triangles.

It is after doing this, I can select faces (very easy now that the model has some to select) and apply the material(s) is desire.

Finally, with respect, please do not respond to a question and point someone to the documentation. It is in no way helpful (and quite frustrating) unless you are pointing to a very specific example of the problem or solution.

$\endgroup$
7
  • 1
    $\begingroup$ No need to assign any materials to be able to select the faces of a model. $\endgroup$
    – brockmann
    Commented May 5, 2021 at 12:16
  • 3
    $\begingroup$ As @Chris said, you probably should make yourself more familiar with terms in Blender and basic modeling. Your first image clearly shows your model has faces. You never have to put a material on an object just to be able to select faces. And if your object wouldn't have faces, putting a material on it won't create any. The first image looks like all those vertices are unconnected (because the edges between them are not highlighted), seems like all vertices are doubled (second image, now vertices and edges are highlighted), one set unconnected vertices, the second set connected. $\endgroup$ Commented May 5, 2021 at 12:19
  • $\begingroup$ Another thing is, you should make yourself familiar with the different selection types in Edit Mode. If you're on Vertex Select or Edge Select then you can't select a face (only if you select all its bounding vertices or edges). And if you add a material on an object and in the material settings you hit "Select", then of course faces will be selected, because a default material (not assigned to certain faces) automatically applies to all faces. But these loose unconnected twin vertices cannot have a material be assigned to - because materials apply to faces, not single vertices or edges. $\endgroup$ Commented May 5, 2021 at 12:28
  • 1
    $\begingroup$ Sorry, another addition: since it looks like you have a twin set of vertices lying over the ones connected with each other, when you select them with Circle or Box Select you almost only select those vertices that are on top of the others - to also select the underlying ones you have to turn Xray on or be in Wireframe Mode. But when you have a model like this, it's best to hit 'A' to select all vertices/edges/faces, then hit 'M' to Merge > By Distance. This usually merges the vertices that are in the same space as others. $\endgroup$ Commented May 5, 2021 at 12:36
  • 1
    $\begingroup$ @StevenFrank That's not how he meant it. And for people giving answers it's frustrating to tell you how something works (and explaining things about faces for example) and then you tell them they are wrong but you found out yourself - and showing with your answer you still don't actually understand how it works. But I hope my comments made it a little clearer what's going on with your model. $\endgroup$ Commented May 5, 2021 at 16:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .